I need help activating my iPhone 5!

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

oriolesfan23

Member
Bronze
Jun 29, 2007
303
0
16
Virginia
#1
Ok, I just got the iPhone 5, and now I can't get it activated. It said I had to download iTunes 7, so I tried that, but it wouldn't let me because it said in order to download iTunes 7 I need Mac Version 10.6.8 or later (I currently have version 10.5.8). I checked for software updates on my computer and it said there are no updates, so how I do download the 10.6.8 version so I can get iTunes 7 and activate my iPhone? Thanks for the help guys!
 

oriolesfan23

Member
Bronze
Jun 29, 2007
303
0
16
Virginia
#3
Yes, I've had every iPhone since the first one in 2007. I have to sync it with my iTunes because I have all my data backed up on there. So I need to download iTunes 7. But I can't figure out how..
 

Zanthe

#apple
Gold
Aug 9, 2007
2,630
314
83
#5
Bro...10.5x? Really? You're way behind and catch up is always a nightmare. I'd really recommend you upgrade to Mountain Lion if your machine is capable. Otherwise Lion 10.7x.
 

oriolesfan23

Member
Bronze
Jun 29, 2007
303
0
16
Virginia
#8
I took my MacBook to the Apple store yesterday. They put Snow Leopard on my Macbook for me (cost $19.99). Then I was able to get iTunes 7 and finally activate my phone! My machine is too old for Mountain Lion.