I want to upgrade to 1.1.2. but...