iCal/iTunes Calendar Sync issue

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

cdodkin

New Member
Bronze
Jul 2, 2007
305
0
0
SoCal
www.d30-images.com
#1
When setting up iTunes to Sync my iCal calendars, It gives me an option to select which calendar to place any new appointments created on the iPhone into. (Sync 'All Calendars' selected in the Info tab)

However, when I try and select anything other than home, it shows it as an option (work for example), but will not let me select it!

Anyone else seen this?

Work around seems to be to select 'Selected Calendars' as the sync option, then tick all the calendars you'll need.

iTunes then allows me to select 'WORK' as the default calendar for new events from the iPhone..

Looks like a S/W bug to me.
 

LauraBee

New Member
Bronze
Jun 21, 2007
85
0
0
Napa, CA
www.flyingcolorstattoo.com
#2
When setting up iTunes to Sync my iCal calendars, It gives me an option to select which calendar to place any new appointments created on the iPhone into. (Sync 'All Calendars' selected in the Info tab)

However, when I try and select anything other than home, it shows it as an option (work for example), but will not let me select it!

Anyone else seen this?

Work around seems to be to select 'Selected Calendars' as the sync option, then tick all the calendars you'll need.

iTunes then allows me to select 'WORK' as the default calendar for new events from the iPhone..

Looks like a S/W bug to me.
I was having exactly this problem! I wanted to choose a specific calendar category for all the events synced from phone to iCal and it wasn't letting me do that, and as soon as I checked "sync these calendars" and checked them all rather than checking "sync all calendars" I was able to specify which one I wanted. Strange, but if it's doing what I want now I guess it doesn't matter...
 

cdodkin

New Member
Bronze
Jul 2, 2007
305
0
0
SoCal
www.d30-images.com
#4
Have you set the time/location for your iPhone?

It's set to Cuppertino by default - and that will skew your iCal schedule

Settings/general/date & time

Make sure the Time zone is set to your local zone, and that time zone support is on.

In the same vein, make sure you do the same in iCal itself!
 

Kozyinn

New Member
Jul 2, 2007
2
0
0
Galesburg, IL
#5
cdodkin You're Awesome! You sure had it right!

I had posted in another area of this site the same problem blackoutcrl was having. I tried a bunch of things but nothing worked. I THOUGHT I had set my time zone on my iPhone but evidently I didn't save my changes. When I re-checked and re-set my phone to my time zone everything was perfect!

I bow to your wisdom and clear thinking! Thanks!