iCloud Email address shows on my iMessages!

Discussion in 'iPhone' started by Ledsteplin, Oct 17, 2014.

  1. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    959
    Thus has happened twice that I recall in the last few days. My iCloud email shows at the top of the other person's iMessage. Once with my Wife and once with my cousin. It happened to my Wife as well. Everything is set correctly in settings >Messages>Send and Receive. It's set the same as always. Does this happen to anyone else? Is it an iOS 8 bug? I only have my number checked in "you can be reached by iMessage at". Wife just said it's been showing my email for days. I have tried this fix. Hoping it works!
    1. Toggle off iMessage and FaceTime.
    2. Reset Network Settings
    3. Enter wifi passcode back in.
    4. Toggle on iMessage and FaceTime.
    5. Deleted all iMessage threads showing my iCloud email and ask the others to do the same.
    [Crosses fingers]
    ImageUploadedByiCafe Forums1413572269.159121.jpg
     
    #1 Ledsteplin, Oct 17, 2014
    Last edited: Oct 17, 2014
  2. bballrob

    bballrob Genius
    Gold

    Joined:
    Oct 11, 2009
    Likes Received:
    461
    How many email addresses does one person need?

    Full disclosure -- I have 7.
     
  3. Keukawater

    Keukawater Member
    Bronze

    Joined:
    Sep 10, 2014
    Likes Received:
    28
    A friend of mine sent me about 10 texts today between 10 and 10:30. Half of them came through normally, from her number, but the other half came through from her iCloud email. That's never happened before. This is the same friend that still can not send iMessages in a group text.
     
  4. missygal

    missygal Zealot
    Silver

    Joined:
    Jul 2, 2010
    Likes Received:
    131
    I text my dad the other day and he got my email addy instead of my number.


    Sent from my iPhone 6 using iCafe Forums
     
  5. MoneyMaker79

    MoneyMaker79 Genius
    Gold

    Joined:
    Dec 15, 2008
    Likes Received:
    340
    This happens often for me without even changing anything. It'll just change to showing my email for my friend.
     
  6. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    959
    Mine did that. Showed my iCloud email rather than number. I posted the fix on another thread I think. But here's the fix:
    1. Toggle off iMessage and FaceTime.
    2. Reset Network Settings and enter the wifi passcode back in.
    3. Toggle iMessage and FaceTime back on.
    4. Delete all affected threads in Messages.
    This worked for me.
     
  7. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    959
    Also have the other person delete the same messages thread.
     

Share This Page