iCloud Keychain problem: Verification not working

Discussion in 'iPhone 6' started by Apple2112, Jan 24, 2015.

  1. Apple2112

    Apple2112 New Member

    Joined:
    Sep 20, 2014
    Likes Received:
    0
    Hello,

    I have tried repeatedly to set up the iCloud Keychain on my 6 plus. I go through the process of "Approve with Security Code. Enter my Apple ID password. Enter my iCloud Security Code. I get the verification code via SMS. Enter the verification code. I let the phone sit there but nothing happens. I can see the little spinning symbol at the top but nothing happens. After a while i give up and after a few days, I get a message on the lock screen that it is waiting for verification.

    Any idea what I'm doing wrong? The same think happens with my iPad 4 and MBP.

    Thanks in advance to all that reply.
     
  2. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,430
    Do you use two-step verification? That complicates it. It took me an hour to get keychain on as a result. I put the wrong iCloud pin in and it locked me out. I then had to use a two-step verification code to reactivate it, even though I looked it up and had the correct pin at that point. The two-step code never came to my phone. I'm not sure why - I think it wanted it to be a different device. A little while later I noticed a code on my old backup phone. After using that code, I was able to toggle keychain on. Apple's instructions for resolving my problem were some of the worst I've ever seen. They just gave me a usesless runaround. I finally figured it out on my own.
     
  3. Rafagon

    Rafagon Genius
    Gold

    Joined:
    Dec 7, 2011
    Likes Received:
    1,236
    I'm pretty sure you've covered this already, but just to double-check, on your MBP (is that the same computer you're trying to sync iCloud Keychain for your iPhone 6 Plus as well as your iPad 4?), if you go to System Preferences > iCloud, you have a checkmark by Keychain, correct? Can you uncheck it, then check it again? After that, go to the Options… button to the right of Keychain, you have a checkmark under Allow approving with security code? Could you please uncheck that, then re-check it? Also, click on Change Security Code… and then Enter a new iCloud Security Code, as directed.

    Now that you have a new iCloud Security Code, go to your iPhone 6 Plus and go to Settings > iCloud, toggle iCloud Keychain to off, then toggle it back to on. Approve with Security Code and, naturally, enter the new iCloud Security Code you created on your MBP.

    UPDATE: I totally forgot about that. @Europa made a very good point. It might need a little extra elbow grease if you have two-step verification enabled.
     
  4. alicepattinson

    Bronze

    Joined:
    Feb 3, 2013
    Likes Received:
    10
    Europa is right, I do experience this too 2 weeks ago and did what europa says. I got it fixed. :)
     
  5. Rafagon

    Rafagon Genius
    Gold

    Joined:
    Dec 7, 2011
    Likes Received:
    1,236
    @Europa 's account of what she did and her instructions were posted tonight. How did you know two weeks ago (when you are telling us you had this experience) what @Europa was going to write tonight? That's quite a feat. I would like to do that too; please tell us how you did it.
     
  6. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,412
    <sigh>
     
  7. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    940
    Just worded wrong. Not everyone is from around here.


    Sent from my ancient but trustworthy iPhone 5
     
  8. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,430
    That user has been reminded several times and then warned twice recently for making fake posts, copying, posting low quality content and for misleading people. Please just report any further suspicous activity rather than replying to the posts. Thanks.
     

Share This Page