iMessage can't send pics.

Peacekepr

Member
Bronze
Jul 30, 2010
65
3
8
#1
Been a while since I last posted ...
I have a 4S and did jailbreak with Absinthe.
I am not sure when the problem started but I can not send pictures using iMessage.
Plain text DOES work in iMessage.
Pictures sent via MMS work.

When sending a picture using iMessage I would get "message delivered" but a friend said he was not getting them. I did a lot of searching and Copic was blamed for this in a few forums - so I removed it.
After removing Copic I still could still not send pictures but now it said "Not Delivered".

I have tried the following:
1. Disable iMessage and Facetime (some forums claimed this may be linked)
Followed by a reboot and reactivation of iMessage - no luck

2. Tried same but used safe mode - no luck

3. Removed most apps - still no luck

Any ideas? I hate to think I may need to return to stock ...
 

Peacekepr

Member
Bronze
Jul 30, 2010
65
3
8
#2
Wow - after hours I figured it out ...
It was not my Jailbroken 4S it was my friends un-jailbroken 4 (with ios 5) that had the problem.
The fix is:
1. Turn off iMessage in phone not receiving messages.
2. Reboot phone
3. Turn on iMessage
 

theorioles33

Evangelist
Silver
Jul 21, 2007
925
136
63
USA
#3
Glad you figured it out and didn't go crazy trying to fix your phone! :)
 

RPMSTL

Member
Bronze
Jun 22, 2009
251
3
18
#4
Nothing worse than spending a day trying to fix something that isn't broke.

I done it a few times!
 

macscac

Member
Bronze
Jun 17, 2009
464
16
18
#6
it was happening to me earlier tonite. I was trying to send pics to my wifes (unjailbroken) iPhone 4.
they wouldn't go.
i removed copic and rebooted.
i then reinstalled the legit copic and paid the buck 29.
all is now working correctly
 

Peacekepr

Member
Bronze
Jul 30, 2010
65
3
8
#7
Update.
Copic is the culprit...
The problem came back again and only went away again after I uninstalled copic.
What threw me is it only affected some image recipiants and then only intermittantly.
Hope copic gets a fix as I really like it!
 

macscac

Member
Bronze
Jun 17, 2009
464
16
18
#8
i can concur.. my picture messages did not get received again by my wife today.
i'm removing copic tonite
 

macscac

Member
Bronze
Jun 17, 2009
464
16
18
#9
Well copic is disabled and I'm still not able to send picture messages
 

macscac

Member
Bronze
Jun 17, 2009
464
16
18
#10
makes me wonder if it's biteSMS
This is really frustrating
 

macscac

Member
Bronze
Jun 17, 2009
464
16
18
#11
biteSMS and copic are both removed... all seems to be working fine now.
we'll see if it continues
 

IceCold357

Contributor
Silver
May 1, 2009
571
39
28
#12
Okay my phone has been doing this for a couple of months and I forgot about it. I don't have Copic but I do have BiteSMS. I will try to remove that and see of that works.
 

IceCold357

Contributor
Silver
May 1, 2009
571
39
28
#13
I removed BiteSMS and I still can't send MMS through iMessage. If anyone has any ideas it would be great. I'm getting frustrated.
 

IceCold357

Contributor
Silver
May 1, 2009
571
39
28
#16
Well I don't get it. I have checked out everything and still cannot send MMS through iMessage to my wife. It says delivered but she never gets anything. I give up.
 

IceCold357

Contributor
Silver
May 1, 2009
571
39
28
#20
Maybe this discussion link will assist you. I read it may be a carrier issue. Has your wife tried taking it in to the store?

https://discussions.apple.com/thread/3396200?tstart=0
Thanks for the link. My wife is under the impression that it is my phone and has nothing to do with hers. I have just accepted that if I need to send her a pic I will need to do it through a text message. Hopefully this issue is fixed with iOS 6.


Sent from my iPhone using iCafe app