iMessage is green all the time now.

Discussion in 'iPhone 5S' started by FFAP1234, Apr 16, 2014.

  1. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    I wonder if somebody could advise me how to bring back the blue color when I text. I don't know if this is a big coincident but right after I registered a new iMac it happened.

    I don't only can send massages as iMessage but I also receive a message saying that it fail. When I send a message it stars blue then it goes green and then I get a fail message info. but actually it delivers. I'm running iOS 7.1. I have tried so many ways to fix it, checked that iMessage is on with the right email and phone #. I have turned on and off iMessage millions of time. Is there somebody that may know what is wrong? My roommate and I use the same account and we both have the same problem. Thank you very much : )
     
  2. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,443
    Go to Settings > Messages > Send & Receive. Does it list your phone number and email address there? Remove the email address and test it with just the phone number. Make sure iMessages is still toggled on before you test it. Are you and your roommate sharing an iTunes account?
     
  3. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    Yes the email and phone # are listed. Yes my roommate and I use the same iTunes account and we both the the same problem when I didn't before. It doesn't let me remove the email.
     

    Attached Files:

  4. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    I didn't realized the pic shows my email addy and now I can't remove it : (
     
  5. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,443
    That email address is what's causing the problem. Do you need to receive iMessages to that address on your phone? If not, I would just remove it. If so, remove it and try adding it back in to see if the problem persists. To remove it you'll need to do this:

    Go to Settings > Messages > Send and Receive.

    Now tap on your Apple ID at the top and an options window will appear. Select Log Out and then only your phone number will be associated with your iMessages.
     
  6. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    I have an iPad that is only wifi and it is blue on that in case that may help.
     
  7. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,437
    I removed the address for you.
     
  8. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    I can try to do that but I always had it set it up that way. Why would it be different now?
     
  9. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    You are a genius! Thank u very much : )
     
  10. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    4,437
    Not a genius, at least not in this case. Just Photoshop. :)
     
  11. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,443
    I'm not sure what went wrong when you set it up on the Mac, but I think the email address is causing the current problem. You can try adding it back in afterwards. I would delete it and test it first.
     
  12. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    I removed the email but didn't solve the problem. ImageUploadedByiCafe Forums1397710963.256464.jpg
     
  13. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    I spent hours with technical support but I didn't have any lack. They said that the iMac has nothing to do with it, however it all started then unless it was a big coincident.
     
  14. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,443
    Toggle iMessages off and then back on. Now make sure Send as SMS when iMessages is unavailable is off and reboot. After rebooting, send a test text. If that works, turn Send as SMS if iMessages is unavailable back on and send another test text. Make sure you are texting someone with an iPhone other than your roommate since he hasn't fixed his phone yet. Since he hasn't fixed it, he can't receive iMessages. You can text yourself for these tests.
     
  15. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    I fallowed step by step as u told me and is green no matter what I do. ImageUploadedByiCafe Forums1397712174.990806.jpg . I'm send it to myself.
     
  16. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,443
    Is iMessages toggled on and activated and is your phone number showing up in the iMessages settings under Send and Receive? Is your phone number the only thing showing up under Send and Receive?
     
  17. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    Yes, yes and yes. I promise u I have tried all kind of different ways. I don't know what else to do.
     
    #17 FFAP1234, Apr 17, 2014
    Last edited: Apr 17, 2014
  18. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,443
    Turn iMessages off, reset your network settings and then turn iMessages back on.
     
  19. FFAP1234

    FFAP1234 Member
    Bronze

    Joined:
    Jun 12, 2010
    Likes Received:
    12
    ImageUploadedByiCafe Forums1397714393.848722.jpg . This is what I get now.
     
  20. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,443
    Try resetting all settings.
     

Share This Page