iMessage not working on WiFi

Iancain

New Member
Apr 11, 2015
1
0
1
#1
Hi, can anyone help me please? I have an iPhone 5s and most i messages do not come through when I am on my home WiFi. The messages come through instantly on my iPad connected to the same WiFi. My wife and daughter both have 5s on the home wifi and their messages come through fine! I find if I turn the wifi of and use 3G it is fine.
Very frustrating, does can anyone help please?
 
Last edited by a moderator:

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#2
Hi, can anyone help me please ?
I have an iPhone 5s and most i messages do not come through when I am on my home wifi.
The messages come through instantly on my iPad connected to the same wifi !
My wife and daughter both have 5s on the home wifi and their messages come through fine!
I find if I turn the wifi of and use 3G it is fine.
Very frustrating, does can anyone help please ?
1. Open the Settings app on the phone
2. Click WiFi
3. Tap the blue circle with an i in it that is on the same line as your WiFi network
4. Select "Forget This Network"
5. Press the Settings button in the top left corner
6. Select your WiFi network and log in
 

Anna Yu

New Member
Oct 21, 2015
4
0
1
#3
First of all, make sure yore connected to Wi-Fi and can browse the web. If so, go to Settings>Messages and then disable iMessage. After a few seconds, re-enable iMessages. After iMessage has been activated, scroll down to the "Send & Receive" section and tap on it. Make sure the "You Can Be Reached By iMessage At" and 'Start New Conversations From" option have the same Apple ID checked.