Installer goes round and around and around and...

panda

Member
Bronze
Mar 15, 2008
143
0
16
#1
When I go into Installer, the little rotating grey "activity clock" beside the wifi reception bars at top left of screen just keeps on going around and around and around. Forever. And again I can't download anything because I keep getting that old "Error: Failed to download package. Can't find host" message again.
What would be causing the round and round thing to happen? Because I figure of I can fix that then the download will work.
I get correct messages when trying to Refresh Sources, but download doesn't work... and that little clock just keeps on going around and...

My iPhone doesn't seem to be successfuly connected through wifi for some reason. It's been fine in the past.

Many thanks in advance for any help.

PS. And the phone heats up as that little clock just keeps on going around and...
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#2
I know there have been several reports lately of Installer not working. Does anybody else have suggestions?

- JoHN
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
26
Boston
#3
it sounds like a Community Sources screw up.

first off, try installing this,
second, do a hard reset
third, reset network settings

if nothing else, SSh into the phone and replace installer with an older version.
 

panda

Member
Bronze
Mar 15, 2008
143
0
16
#4
it sounds like a Community Sources screw up.

first off, try installing this,
second, do a hard reset
third, reset network settings

if nothing else, SSh into the phone and replace installer with an older version.
Excellent, thanks. Now...
1. When you say "first off, try installing this", what exactly is 'this'?
2. By hard reset, do you mean holding down power button until red slider appears, then sliding that and waiting for the full turn-off then rebooting with the Apple symbol etc?
3. Reset network settings - do you mean re-entering info or is there a reset function somewhere in Settings? (I have BossPrefs installed if that helps, but I still can't find a Network Reset function).
4. Where would I find an installer package for an older version of Community Sources? (Pity - I love that search function!)

Apologies if my questions all sounds a bit simple.
Thanks
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
26
Boston
#5
1) try downloading Community Sources, that is, by uninstalling and then installing if you already had it installed.
2) what you are talking about is a soft reset. a hard reset is when you hold down home and sleep until the phone shuts off, then proceed to turn it on manually.
3)Yes, there is an option in Settings.
Settings-->General-->Reset--->Reset Network Settings
5) I haven't a clue where you may find an older version of Installer, except the Google on the Internet machine.
if you do find one, it'll be in a .zip format, and inside, there will most likely be a folder named Installer.app
Browse into the phone, delete the original Installer, and place the Installer app in there instead.
if that doesn't help.... well, its time to restore and rejailbreak.
 

panda

Member
Bronze
Mar 15, 2008
143
0
16
#6
2) what you are talking about is a soft reset. a hard reset is when you hold down home and sleep until the phone shuts off, then proceed to turn it on manually.
I always thought this would create a full Recovery Mode situation on the iPhone, but I guess that'd only be if I continue to hold those buttons down for a longer time after the red slider appears, like when I originally did my Restore-and-ZiPhone OTB?

Brilliant, thanks for all that. Really appreciated. I'll do that now. I'm hoping like crazy that restore and jailbreak isn't necessary.
---
BTW, themanofthedark... you really keep some serious hours! This forum must be like home for you! Thanks for that.
 

panda

Member
Bronze
Mar 15, 2008
143
0
16
#7
Success!

1) try downloading Community Sources, that is, by uninstalling and then installing if you already had it installed.
3)Yes, there is an option in Settings.
Settings-->General-->Reset--->Reset Network Settings
Ok did those 2 items and all s back to working great. Thanks! I was worried about #2 reset (would like some confirmation on that being ok and not leading to Recovery Mode) and was reluctant to restore.
So it worked, thank you. Cheers!
 

themanofthedark

New Member
Gold
Jan 5, 2008
2,674
0
0
26
Boston
#8
Ok did those 2 items and all s back to working great. Thanks! I was worried about #2 reset (would like some confirmation on that being ok and not leading to Recovery Mode) and was reluctant to restore.
So it worked, thank you. Cheers!
excellent.

hope it helped.
 

panda

Member
Bronze
Mar 15, 2008
143
0
16
#9
Yet again... on Installer v3.11

excellent.
hope it helped.
Hi sorry but it's me again. Last time your suggestions did work. Now though, same *!@%*%! problem as before... going around and around... I'm really trying to avoid the 'Full Restore and re-Jailbreak/re-Unlock' option, partly because I'm traveling for quite some time. I'm now using Installer v3.11. I have now uninstalled Community Sources and now can't reinstall because of that *!@%*%! message "Package download failed. Can't find host".

I'm a bit concerned about the Community Sources no longer being my iPhone. I'm not sure of the implications of that.

Btw, I've checked there's no shortage of free space on the partition either.

I'd really like to get this solved again.
Any suggestions?
Many thanks in advance