Internet & all server problems

trnsilver

Zealot
Gold
Feb 2, 2008
1,124
6
38
Florida
#1
This is really strange and I haven't found any answers so far on the net.

Two days ago my iPhone stopped connecting to the server. Basically it will not load internet pages, will only sometimes access my e-mail, stocks and weather and won't work with Maps.

The Internet load bar only fills up a little and then just stops.

The Internet DOES work on WiFi...but not through the server (AT&T, EDGE, what have you).

I have driven to different locations in my city to make sure it is not the service in my house (full bars in my house and everywhere).

I've turned the iPhone off and on to let it reset.

I've restored my internet and settings back to factory.

Nothing is working.

I am probably going to go to the Apple store tomorrow but here are my questions:

1) Has anyone had this happen to them?
2) Is there a way to fix it?
3) Will Apple do anything to help me? (i.e. if they can't fix it, give me a new one?) I've only had it for a few months.

Thanks, all!
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#2
If you have restored your original settings and you're still having problems, then taking it to Apple is the best option.
 

electoman

New Member
Bronze
Sep 20, 2007
127
0
0
Atlanta, GA
#3
It is possible that AT&T is having a problem with its data network and may clear up on its own.
 

mrmacbook

New Member
Bronze
Jun 13, 2007
139
0
0
#4
I've been having similar trouble the past about week. I think it's their end because over wifi everything works great.
 

trnsilver

Zealot
Gold
Feb 2, 2008
1,124
6
38
Florida
#5
electro...that is what I was thinking...but 3 days? Also people in my same area that have iPhones are connecting w/o a problem. I have 3 friends that have it.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#6
Have you tried Settings/General/Reset and reset the network settings yet? That's what I would do first.
 

electoman

New Member
Bronze
Sep 20, 2007
127
0
0
Atlanta, GA
#7
electro...that is what I was thinking...but 3 days? Also people in my same area that have iPhones are connecting w/o a problem. I have 3 friends that have it.

I don't know then. Sometimes my phone does that but a simple power off corrects it and I feel that it has to do with the network and whether or not it recognizes my device. Call AT&T and tell them you are having a data issue and want to speak to the data department. Don't let the regualr customer service walk you through their steps. The iPhone (and other data devices are over their head). The data people are usually pretty good at getting these types of problems resolved.
 

trnsilver

Zealot
Gold
Feb 2, 2008
1,124
6
38
Florida
#8
Just got back from the Apple store...guy told me pretty much what you did, electro, that it is an AT&T problem. He suggested I fully restore my phone (which I did with no positive results) and then call AT&T and have them remove the data plan from my account and then put it back in. He said that would work.

I will try that and let you guys know.

Starting to get pretty frustrated. I've loved this phone until now and Internet was the main reason I got it.