iPhone 3GS 3G Signal has stopped working?

hazzyson

New Member
Sep 4, 2011
1
0
1
#1
Hey guys,

I switched providers yesterday and I called them up and got them to activate my account as a 3G account, etc, etc. After I got off the phone with them, I turned on my 3G service on my iPhone (General --> Network--> Enable 3G) and it was working fine. The 3G symbol, speed, and all was all fine and dandy, I was using it to surf the web and whatnot...

This afternoon I was using it and suddenly my 3G signal went off... Not the option itself, the signal. I have tried restarting my phone, restarting the 3G switch, and whatnot, to no avail...

I have called my provider and they said there's no current issues with their 3G network, so I guess it's my phone unless they'd be lying for some reason... I AM within 3G coverage area, I'm at home, the exact spot where I originally got my 3G service...

It's weird because it just happened completely randomly without any sort of notice... Which led me to believe it was a fault on the side of the provider, however I asked them numerous times and they continuously tell me there's nothing wrong with their side of the network..

I have tried restarting it, putting it in Airplane Mode and back, Resetting Network Settings and that stuff.. No avail.. :\
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
701
113
#2
Have your tired your SIM in another phone or another SIM in your phone? You would be able to work out if it was a hardware issue.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,506
113
Utah
#3
Does the phone have a 3G signal when leave your house and switch towers? If so, I'd give it a couple of days. I've had my 3G coverage disappear at my house a couple of times and it lasted for a day or two. It was a problem with the tower, yet AT&T said the tower was fine when I called them. Which provider are you using?