iPhone 3GS charging issues in car

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#1
Hi,

just tried hooking my 3gs up to my BMW using the 6fl lead and i get the message "this accessory doesn't support charging".

Anyone had this problem? Any ideas?
 
Jun 19, 2007
33,493
4,550
113
Upper Marlboro, MD
#2
Try it a couple more times. My Griffin charger did the same thing for my 3G and 3GS, then all of a sudden it started working, albeit with a warning which I could answer "no" to.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#3
Ill give it a restore then go again... its so annoying. When i had the 3g i could say no and it would still charge etc, but this time i have an error that doesn't let me say, effectively, charge anyway!
 

rgs3

Member
Bronze
Sep 7, 2007
34
2
8
#4
Hi,

just tried hooking my 3gs up to my BMW using the 6fl lead and i get the message "this accessory doesn't support charging".

Anyone had this problem? Any ideas?
Did you previously have a V1 iPhone that did charge in your car? The V1 uses 12V firewire charging which most manufactures support but Apple suddenly changed this in 3g and 3gs. The newer models use USB charging and the pinouts are different. I had to get an adapter for my car to charge my 3g. I got the Scosche passPORT Charging Adapter for iPhone 3G from Apple and its worked flawlessly. Very sucky that we have to do this though. The phone doesn't fit where it used to now that i need this 1 inch thing attached to the bottom of the phone in order to charge.
 

Aaron

Member
Bronze
Jun 26, 2007
77
0
6
#5
+1 on the Schosche PassPORT Just ordered one today.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#6
No i had a 3g that used to charge, its a bmw 6fl lead, which was marketed to charge the iPhone 3g. This was the newer lead to correct the port changes.

Ive tried a restore and all sorts.... nothing working. ARHHHHH I hope we wont have to buy another £40 lead. Could be a BMW car software update. Not sure how i would go about reporting this though? To Apple or BMW?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#7
Just tried mine and it charges. I've got a Sony with a USB input.
 

whale_hunter

New Member
Bronze
Sep 11, 2007
207
0
0
#8
I have a cheap $20 charger that I bought for my first gen iPhone and it works fine.

Suprised you're having trouble.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#9
This is one of those things thats going to piss me off! The 6fl lead (supposedly) charges the phone, whilst letting you play music with display info through the built in unit. The music works but its just the charging. I guess it must be a BWM software update issue then?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#10
I have a cheap $20 charger that I bought for my first gen iPhone and it works fine.

Suprised you're having trouble.
We're talking about car stereos that play music from the phone, let you control that music from the stereo, and charge it at the same time. There are sometimes incompatibilities where they will play the music but not charge the phone.
 

JoeT

Member
Silver
Dec 18, 2007
911
0
16
Tampa, FL
#11
All the chargers that I used with the 3G have worked with the 3Gs.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#12
All the chargers that I used with the 3G have worked with the 3Gs.
Are you referring to a car stereo that connects through USB and plays music while charging?
 

notjustgc

New Member
Bronze
Jun 18, 2009
36
0
0
#13
I had this issue with my car adapter; the simple (and only) fix was the already-mentioned Scosche Passport. Read manufacturer's info here, then buy it on Amazon here. You plug it in, it works, 'nuff said.
 

iNinja

Zealot
Gold
Aug 8, 2008
3,984
20
38
UK
#14
I had this issue with my car adapter; the simple (and only) fix was the already-mentioned Scosche Passport. Read manufacturer's info here, then buy it on Amazon here. You plug it in, it works, 'nuff said.
I appreciate the link but if you read the post I already had a new cable that charged a 3g with no problems. If the ports are the same on the 3g and 3gs, it can only be a software issue on either Apples end or BMW end?
 

btpcar

New Member
Jun 21, 2009
1
0
0
#15
i have the same problem. my 3g charged fine, but the 3gs does not charge. i'm using the Apple cable that has power and A/V L/R/Composite out. Some cheap dual usb output charger the plugs into cig. lighter.

any advice would be helpful...
 

notjustgc

New Member
Bronze
Jun 18, 2009
36
0
0
#16
Something JUST happened that I thought may be of interest in regards to this thread. I plugged my 3G S into my Belkin wall charger only to find the "charging is not supported" message popped up! I charged the same phone with the same charger last night, so I clearly knew my 3G S was a dirty LIAR! Unplugging and plugging in a few more times quickly remedied the issue. Nevertheless... strange indeed.
 

psylichon

Genius
Moderator
Oct 31, 2007
16,591
751
113
41
Philly
#17
Check your dock and cable connectors for any dust, lint, hairs, anything that would affect connection. The Apple iPod dock connector protocol is an extremely fickle beast! Block one pin and the whole system goes bonkers.
 
Jun 28, 2009
1
0
0
#18
I have exactly the same issue with my 2008 BMW 3-serie Touring with 6FL. My iPhone 3G works, both iDrive and charging, but with my new iPhone 3GS only the iDrive works, and it does not charge.
 
Jul 20, 2009
1
0
0
#19
No i had a 3g that used to charge, its a bmw 6fl lead, which was marketed to charge the iPhone 3g. This was the newer lead to correct the port changes.
Croucher, if it makes you feel any better I'm in the same boat. I've tried my iPhone 3GS in two other BMWs (older models actually) and it charges, but it does not charge in my 2009. Also, other iPhones charge in mine. I've also tried different cables to no avail.

If enough people report this problem Apple and BMW will figure it out so I suggest you report it to your service center if you're under warranty. I hope it's an iPhone 3.0 issue and not a BMW issue.
 

Bryman

Member
Bronze
May 30, 2009
224
0
16
colorado
#20
i get that with my monstercable car charger what the heck? says incompatible charger?