iPhone 4 - Error when trying to update and preserve baseband - HELP!

Discussion in 'iPhone Jailbreak' started by candn14, Feb 3, 2012.

  1. candn14

    candn14 New Member

    Joined:
    Jan 27, 2012
    Likes Received:
    0
    Right i have literally tried EVERYTHING but still its not working!

    I have a iPhone 4 running 4.3.3 and 04.10.01. I am trying to update to the latest firmware but keep the baseband 04.10.01 as I am using a Gevey Sim to unlock the iPhone as its on AT&T!

    When i try to restore it using a NO BB firmware made by Redsnow i keep on getting this error message - "The iPhone could not be restored. This device isn't eligible for the requested build"

    I have tried the following to sort it out

    - Updating the latest iTunes

    - Updating my Macbook Pro to the latest software

    - Going in the 'host' folder in the /private/etc and then adding a # infront of the Apple line in that folder.

    - Cleared the cache on the Macbook Pro

    - Tried using the 5.0 and 5.0.1 firmware all going through Redsnow to preserve the Baseband.

    I really do not know what else i can do now!

    What do you think guys and girls? What else is there left to do? All i am wanting to do is update to the latest firmware but keep my existing firmware i have been on so many websites and tried so many different things but all end with the same error message!

    I am trying to do this so i can sell it on as i have just upgraded to an iPhone 4S White 32GB Unlock!
     
  2. iphonewarrior

    iphonewarrior Moderator
    Moderator

    Joined:
    Apr 11, 2008
    Likes Received:
    701
    Thread moved to the iPhone Jailbreak section.
     
  3. fijiman

    fijiman Contributor
    Silver

    Joined:
    Feb 13, 2011
    Likes Received:
    64
    Are you using the correct ipsw firmware for your iPhone 4...?
     

Share This Page