iPhone 4 lag

IllusionEntity

Evangelist
Gold
Jun 3, 2010
1,987
163
63
Borough Green, Kent, UK
#1
Hi Guys.

My phone has been running smooth as hell but today and now the touchscreen is a bit off... It like... If I swipe to a different screen it will jolt and show half of the next page and then come back quickly. The multi-task bar takes 4-5 seconds to load up.
I just have lag in general.

Whats going on? I am restoring now but I don't know if it will fix the problem
 

jopiej

Member
Bronze
Jun 19, 2009
77
0
6
Planet Earth
#2
Funny, i just experienced that laggy screen too. Restarted the phone and everything back to normal.


Sent from my iPhone using iCafe app
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,756
113
PA
#5
What firmware are u running?
 

JWiPhone

Genius
Gold
Sep 18, 2007
6,357
447
83
Los Angeles, CA
#7
I had the same problem with 4.2.1. What helped me though was to shut down the apps running in the multi-task bar. It doesn't have to be all of them but just a portion of them, and I noticed my iPhone was working great again as normal.

It is probably a memory issue.
 

JWiPhone

Genius
Gold
Sep 18, 2007
6,357
447
83
Los Angeles, CA
#9
Memory issue? What do you mean?
Just like a computer your iPhone allocates so much memory that can run low if too many programs are running. I use AppSwitch app (99 cents) that shows me how much memory is being used. All I know is that my iPhone 4 was very laggy with 4.2. For example, I would have to hit my home button twice before my screen would move. After I shut down programs in my multi-task bar my iPhone was very responsive again with no more lag.
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,756
113
PA
#10
I'm having "some" lag issues as well plus battery draining a lot faster and photo not displaying properly.
I'm doing a restore and so should you, just make sure you sync and back your phone up before you do anything.
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,756
113
PA
#12
Man you guys are fast. Try JW solution first, I'm still doing a restore only because I'm not happy with the battery
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,756
113
PA
#13
So are we thinking that this is a 4.2.1 issue guys? As I got my iPhone 4 replaced Saturday brand new
In my case it is, and I'm not the only one, but I never noticed a big lag like you're saying, that's why you should try JW solution first and see how it goes
 

IllusionEntity

Evangelist
Gold
Jun 3, 2010
1,987
163
63
Borough Green, Kent, UK
#19
Ok guys! Restored and set up as a new phone, No lag now but we shall wait and see! Please update the firmware now Apple! An unrushed firmware if you don't mind!