iPhone 4 - no connection to data network

Discussion in 'iPhone' started by h.s, Sep 10, 2010.

  1. h.s

    h.s New Member

    Hi everybody,

    I'm experiencing a strange problem with my (otherwise lovely) new iPhone 4:

    The connection to my carrier's data network is not working. The phone shows the "E" or the "3G" sign, respectively, but if I open e.g. Safari, the "Cannot open page, no connection to the internet" window pops up. Same with Maps, Cydia etc.

    The carrier's service team confirmed to me that the data plan is correctly booked and they can even see that I connect to the network. The guy said, however, that each connection produces only tiny traffic, obviously no "real" connection. He said that he saw this for the first time and strongly suspects that the problem is on my side.

    APN, user name and password are definitely correct; SBSettings confirms that I got an IP address to the data network. WiFi, phone, GPS etc. work all fine.

    This is very, very strange. Anybody got an idea? I am officially flabbergasted and out of ideas.

    My setup:
    • iPhone 4 16 GB factory unlocked from UK
    • Using it in Germany, carrier Simyo
    • iOS 4.0.1, jailbroken

    It's almost as if my traffic is pointing to a dead proxy or something. If somebody could direct me which setting and/or logging files to check via SSH, that might a big help!

    Right now I have neither access to a different iPhone or an adaptor tray to check my SIM card with a different phone (no different Micro SIM at hands, either).

    Thanks for your help... iPhone without data connection is only half the fun :-/
  2. Watcher

    Watcher Zealot

    First try Settings > General > Reset > Reset Network Settings and then Reboot, which you accomplish by holding the top Sleep/Wake button at the same time you hold the bottom Home button until you see the Apple logo; then let go of both buttons. And if that doesn't alleviate your issue try Settings > General > Reset > Reset All Settings, keeping in mind you'll have to re-enter email account information, passwords, etc., and do a Reboot. If neither of these methods help fix your issue, I would highly recommend that you restore your iPhone as a new phone through iTunes to get the cobwebs out.
  3. Avatar

    Sponsored Advertisement

  4. h.s

    h.s New Member

    Un-freaking-believably. I don't know how often I tried this, to no avail - so I thought "well , let's go through the motions, just so I can say I tried". Only this time it worked, everything's up and running. Thanks a bunch, you made my whole weekend :)
  5. Watcher

    Watcher Zealot

    No problem! I'm glad you got it working again.

Share This Page