iPhone 4 not receiving all Gmail messages

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up
Oct 14, 2012
2
0
1
#1
I really don't use my Gmail address (name at gmail.com) in my Gmail account. I use the Gmail email platform to receive and manage all of my email messages from other accounts (rob at otheraccounts.com).

I do not have Gmail or the Gmail app installed on my iPhone 4. I have all of my email accounts directly set-up into my iPhone from their respective servers. Since I stopped using MS Outlook and set up Gmail to receive all of my email messages, I am finding that all of my emails are being received in Gmail, but some of them are not being received on my iPhone. It seems like Gmail grabs all of my emails, but my iPhone only receives a portion of them. I did not have this problem when I was using MS Outlook.

Any thoughts?

Thanks,

Rob Caldwell
 

MrMike6by9

Evangelist
Gold
Nov 16, 2008
1,482
120
63
69
Maryland, USA
#2
There are several possibilities. Do you have gmail set up as imap, for example? I have 3 gmail accounts set up that way; all accessed through the mail app. About a month or so ago, one failed to connect while the others functioned normally for about a week until that misbehaving one started working normally again. No explanation found. However, all accounts remained accessible via a browser or through the gmail app. On the other hand, if you are forwarding the other accounts to gmail as an aggregator, make certain your other accounts are not being seen as spam by gmail. You can check the spam folders within the gmail account. BTW, I have 3 gmail, 2 yahoo, and a hotmail account all working through the official mail app. Some random ideas just offered as food for thought.
YMMV


Any impatience you show will only create more stress.
 
Oct 14, 2012
2
0
1
#3
There are several possibilities. Do you have gmail set up as imap, for example? I have 3 gmail accounts set up that way; all accessed through the mail app. About a month or so ago, one failed to connect while the others functioned normally for about a week until that misbehaving one started working normally again. No explanation found. However, all accounts remained accessible via a browser or through the gmail app. On the other hand, if you are forwarding the other accounts to gmail as an aggregator, make certain your other accounts are not being seen as spam by gmail. You can check the spam folders within the gmail account. BTW, I have 3 gmail, 2 yahoo, and a hotmail account all working through the official mail app. Some random ideas just offered as food for thought.
YMMV


Any impatience you show will only create more stress.
I am not using IMAP. My accounts are set up in Gmail as POP3 (on my Laptop).

I am not sure I understand your suggestion to check my "spam folders within my Gmail account". There is not an issue with me receiving messages in my gmail account. I check my Gmail messages on my laptop computer. When I am on the road, I want to see my messages on my iPhone. All of the messages are being received in my Gmail account (Laptop) but not on my iPhone. I did not have this problem when I was using MS Office (Laptop) and was able to receive all of the same messages on my iPhone.

Thanks,

Rob Caldwell
 

EverythingApple

Evangelist
Gold
Jul 28, 2010
3,859
224
63
North Jersey
#4
The only way to see all emails on all devices is to use IMAP. If you are using the POP (Post Office Protocol) which is one way, that is why they aren't showing up on your iPhone. Try changing it to IMAP and see what happens. They are downloading to your laptop via POP and ending there.
 

MrMike6by9

Evangelist
Gold
Nov 16, 2008
1,482
120
63
69
Maryland, USA
#5
The only way to see all emails on all devices is to use IMAP. If you are using the POP (Post Office Protocol) which is one way, that is why they aren't showing up on your iPhone. Try changing it to IMAP and see what happens. They are downloading to your laptop via POP and ending there.
Agreed. I abandoned POP3 years ago for any account that me gave the option to use IMAP. Good luck!