iPhone 5 Jailbreak Glitch

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#1
At least five times in the past week my dock and dock apps have started flashing in a rapid strobe-like pattern about 3 times per second. It only happens when I'm on a phone call (I use a Bluetooth headset, so I am able to see the screen when I'm on a call). It goes away when I lock and unlock the phone. I'm not using WinterBoard or any dock tweaks.

Is anyone else experiencing this?
 

coop1701

Zealot
Silver
Jun 30, 2007
899
114
43
#4
I use Bluetooth in my car and I have not seen this Europa... But I will run through a few tests this afternoon and see if I can make it happen.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#5
My best guess is that it's Auxo. It's one of my favorite apps, but it's fairly buggy. It seems to have bug fix updates every day or two. I'm tempted to uninstall it for a while and just use SBSettings.
 

Santa

Evangelist
Gold
Jul 2, 2009
1,122
115
63
Colorado, USA
#7
I've got Auxo, so I'll watch for it. I use bluetooth mostly, but I don't usually look at my screen. I've gotten used to Auxo. I'd hate to have to dump it.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#8
Just happened right after a phone call again. I still have Auxo installed. I'm just waiting for a couple more people with Auxo to experience the same thing and then I'll contact the developer. Right now I just suspect that it's the cause.
 

coop1701

Zealot
Silver
Jun 30, 2007
899
114
43
#10
I use bluetooth in my car that is a visor clip on type. I used it and watched for what Europa reported. I also have Auxo but it did not happen to me. It worked just fine.

Europa.., I noticed before on a screen capture a long time ago, that you get the bluetooth battery indicator to come up on your status bar. If you use Springtomize, maybe that's causing it. None of bluetooth products allow for the battery indicator at the top.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#11
I use bluetooth in my car that is a visor clip on type. I used it and watched for what Europa reported. I also have Auxo but it did not happen to me. It worked just fine.

Europa.., I noticed before on a screen capture a long time ago, that you get the bluetooth battery indicator to come up on your status bar. If you use Springtomize, maybe that's causing it. None of bluetooth products allow for the battery indicator at the top.
I'm not using Springtomize.

Actually, a few of them do. The Bluetooth headset battery meter in my status bar is a stock Apple indicator. It only works with compatibile headsets, and most headsets are not compatible with it. I'm using a Jawbone ICON HD. The old Apple Bluetooth headset (now discontinued) was the first to work with it.

I did notice that it tends to happen at the beginning of a phone call. It's very infrequent, though. I had a lot of calls yesterday and it only happened once. It doesn't happen every day.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#12
Europa, did you manage to find the culprit? Is the glitch causing a Safe Mode crash or is the display simply, jumpy?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#13
Europa, did you manage to find the culprit? Is the glitch causing a Safe Mode crash or is the display simply, jumpy?
No, it's not crashing. It's just a display glitch that goes away when I lock/unlock the phone.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#14
That's quite random. I take it you've tried the old hard-reset thingy and it's not fixed it..?

Did your phone do this when it was stock?


Sent using iCafe app
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#15
That's quite random. I take it you've tried the old hard-reset thingy and it's not fixed it..?

Did your phone do this when it was stock?
Yeah, I've done several hard resets. I'm sure it's related to one of my Cydia apps or tweaks. It never happened when it was stock.
 

AdamDaieh

Member
Bronze
Jan 17, 2013
141
7
18
California
#17
I have Auxo too but I have not having this issue, but I'll check on it. :)
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
702
113
#18
Auxo is quite buggy and does cause a lot of issues. I think once the codes refined it'll start to be behave nicely :)
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#19
I've had the flashing dock occur about a hundred times now. 100% of the time it happens when I'm on a phone call (Bluetooth or headphones) with the screen locked and then slide to unlock. It's not consistent and only happens one or two times a day.

I've ruled out Auxo as the culprit. It has been uninstalled for a week and the problem is still occurring. After a couple months of deduction, I'm now leaning towards Shrink as the culprit. I just uninstalled Shrink and I'll run my iPhone with gargantuan icons and unsightly icon labels for a few days to test and then I'll post back. I don't want to install any apps with similar functions during the testing, so I'm avoiding Springtomize.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#20
I was pretty happy to see the dock flash today because that meant I could reinstall Shrink. It was a long week without it. I don't have much left to rule out. I'm uninstalling Unfold now as it's next in line. The problem always occurs right after unlocking, so I have a pretty good feeling that it's the cause. I also occasionally have SB crashes after unlocking and it might be causing them as well. No culprits listed in Crash Reporter with that.