iPhone 6 Plus WiFi appears slow

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

rattlhed

Member
Bronze
Feb 16, 2009
61
17
8
Bellevue, WA
www.rtaphotography.com
#1
So like most Apple fans out there, once you get your new device you want to send it through all its paces. I've been playing with my iPhone 6+ constantly since yesterday afternoon. One of the first thing I did was jump into Apple and Google maps to see how amazing they look in the big screen. But I noticed it was taking an unusual long time to load maps up. So I dug a little further. First I wanted to see what LTE would be in comparison. Way faster! Almost instant which is what I used to get on WiFi with my iPhone 5. Then I did a side by side WiFi comparison to see if maybe it was just my WiFi network that was bogged down or slow. Not the case. Loading the exact same web sites was at least 3x as fast on my iPhone 5 compared to my iPhone 6+.
Final test, use the Ookla Speedtest app. I made sure I was connected to the same server on both phones and ran the speedtest 3 times. I tried this with several different servers just to rule out any flukes. Each time the iPhone 5 was miles ahead of the 6+. The only way the 6+ could compete was to be over LTE, then they were about equal. Here are my results:

As you can see the 6+ isn't even close. And this was pretty consistent for the several servers I tested it on. I've tried doing a full reboot of the phone as well, no luck.

Based on these results, I'm pretty convinced there is something wrong with the WiFi antenna on my phone. I'm going to keep plugging away for a couple more days but if this keeps up its back to the Apple store for an exchange. Curious if anyone else is experiencing this. Hopefully it's just my phone and not a case of serious hardware issues with the 6+.
 

JWiPhone

Genius
Gold
Sep 18, 2007
6,323
421
83
Los Angeles, CA
#2
That is about what I get on my Ookla speedtests for WiFi and LTE. It was the same for my old iPhone too. My Verizon broadband service I subscribe to only goes up to about 6 mbps for download so that is in the correct range for me.
 

Ddrumbum

Member
Bronze
Apr 14, 2011
59
19
8
#3
Hmm weird, I just performed the same test and my speed is fantastic and much better than my 5S. Maybe reboot your router and phone and see what happens, if it continues, I would call tech support.
 

Torinate

Member
Bronze
Sep 19, 2009
325
7
18
#5
Reset your Network settings.

You'll have to put in your wifi password again.

Reboot your modem as well.

Good luck!
 

Ledsteplin

Genius
Gold
Oct 29, 2013
4,791
979
113
65
Florence, AL
#7
Try what @Torinate suggests. Go to settings>general>Reset>Reset Network Settings. Enter in your wifi passcode afterwards. Also reboot your wifi router/Modem by unplugging it for 1 minute. Then if back in. If you still have issues, visit a Genius Bar or your carrier store.
Make sure when you test with SpeedTest.net, that you use the same location for each device.