iPhone always enters safe mode

Dec 8, 2008
14
0
0
Huntsville, Alabama
#1
Hey guys. I've been reading on this forum for a long time now, and just recently decided to make an account. So I used the guides here to Jailbreak my iPhone 3G on 2.2 with QuickPwn :). My problem is that just recently every time I turn it off it goes to safe mode. It says to restart the iPhone to cancel this, but when I do it just goes right back. I can, however, just reset Springboard and it works fine from there. It is just really frustrating that every time I turn it off and turn it on it takes 5 minutes to load and enters safe mode. So I'm not sure what to do? I have taken all of my themes and stuff off of Winterboard and then reset it, but that did not work either. What am I to do :s?
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#2
Unfortunately, it isn't really something that you can solve unless you uninstall WinterBoard (WinterBoard installs Mobile Substrate, which brings Safe Mode to the table). For some reason, phones are kicked into very frequently. Why this Safe Mode is necessary, I have no clue.
 
Dec 8, 2008
14
0
0
Huntsville, Alabama
#3
I suppose I will uninstall Winterboard and then try to reinstall and see if it fixes it alittle. If it doesn't do it every time from that then I will be pleased haha. Thanks for the help.

Edit: I unistalled and reinstalled Winterboard and then rebooted it. When I did it returned to the good ol' safe mode. Not sure what to do.
 

Lincoln

New Member
Gold
Aug 11, 2007
6,100
4
0
#4
So does it kick into Safe Mode every time you reboot? If so, that's a bit strange. Mine just does it spontaneously whenever I unlock it.
 
Dec 8, 2008
14
0
0
Huntsville, Alabama
#5
Yeah it enters Safe Mode every time I reboot it. It just started doing this yesterday for me, although it did do it one time a few days before. Now every time I turn it off and on it enters it.
 

chaanakya

New Member
Dec 21, 2008
2
0
0
#6
Consider yourself lucky

My iPod Touch actually fails to boot... it boots up, resprings, resprings again, reboots in an infinite loop. The only way to get it to boot up is by sshing in and renaming the /var/mobile/Applications folder to Applications.bak, let it boot up, rename the folder back to Applications, and respringing. The annoying part is that MobileSubstrate doesn't even kick SpringBoard into safe mode. By the way, Safe Mode is a way to (supposedly) get SpringBoard to start where it would otherwise give you SWOD (Spinning Wheel Of Death). I for one am glad Mobile Substrate has a safe mode to fall back on if anything goes wrong. The fact that I have 185 apps may have something to do with the fact that I have to do this renaming businesss to get it to boot up :laugh2:
 
Dec 8, 2008
14
0
0
Huntsville, Alabama
#7
Oh yeah Im glad that it does it rather than that haha. Im not sure what to tell you on that. Im just curious what I should do now though.
 

chaanakya

New Member
Dec 21, 2008
2
0
0
#8
I would do what I do whenever my iPod isn't booting up (see my previous post). That way, you can see if it is one of your applications that is causing SpringBoard to go into Safe Mode.
 
Dec 8, 2008
14
0
0
Huntsville, Alabama
#9
Well after deleting random stuff I downloaded off of Cydia I found what seems to be the problem: SBSettings. Now that I have deleted it I have rebooted it roughly 5? times and it never went into safe mode. I downloaded SBSettings again and the first reboot was fine, and then after it went into safe mode again. So thanks for the help guys, I guess I will just have to live without SBSettings :/