iphone detects wifi network, but doesn't connect online with it

Discussion in 'iPhone' started by lechon, Sep 18, 2007.

  1. lechon

    lechon New Member

    here's my deal:
    -I have wifi turned ON
    -under the "choose a network" section, it lists the available wifi networks (it shows the wifi icon displaying the signal strength)
    -I click the desired network to choose it (it places a checkmark to indicate)

    when I open safari, it doesn't even attempt to use wifi (no wifi icon appears), it automatically gives me the message "safari can't open the page because it can't find the server"

    I thought it was my linksys router, however I've tried this with 2 other routers, which gives the exact same result. needless to say, it's very frustrating!

    can anyone help? do I happen to have a wifi-crippled unit?
  2. coyotensc

    coyotensc New Member

    this is the same problem I am having.

    the only difference is that mine did work when I got my iphone in july. this past friday, it started doing the same thing you are describing.

    still no solution yet.
  3. Avatar

    Sponsored Advertisement

  4. PirateMike

    PirateMike New Member

    I had a similar problem with my Linksys router. Sometimes it would work, sometimes it wouldn't. Sometimes It would freeze my iPhone for 5 minutes trying to connect. I gave up and purchased an AirPort Extreme and have not had any problems since.
  5. iPat

    iPat New Member

    Experiencing a similar problem. Phone connects to the network at my office fine, and always is connected to the net. At home today I noticed that it connects to the network, but won't display the signal(still have the E edge box)up top. When I go into the wifi settings there is no IP displayed....
    Anyone have thoughts on this?
  6. Baloney Fist

    Baloney Fist New Member

    I started having similar trouble this morning after not being able to connect at all very early in the morning. I had an Office service pack pending install which was the only thing that was different on my system, although I don't know if that was related. Once I installed the service pack, I restarted my desktop and I was getting E and then the WiFi signal. I went into my Netgear setup and reapplied the access for the iPhone and haven't any troulbe since on my home network. I did go to the Coffee Bean this afternoon and connected to the att wifi with my account, but I got booted twice and gave up. I have not had any trouble staying connected before.
  7. Lazarus

    Lazarus Member

    I'm now too just staring to have this problem. I'm on edge posting this np. But wifi just won't. I been on 2.0.2 for a week with np till now. I did just install some wifi apps I'm thinking maybe files or another one f'd it up. Any solutions please? Restore?
  8. Lazarus

    Lazarus Member

    well fixed my problem lol my wifi and my boys wifi have the same name so I just had to tell it to stop auto connecting to mine and start a fresh connect to my boys and alls good. I'm glad it was something simple maybe I'm not the only one lol
  9. Plazman

    Plazman New Member

    Thanks for posting the solution you found Lazarus. I've been having this problem at home too. I did recently change my wi-fi config, so maybe it's only looking for an "old" version of my network. I'll try it out tonight! :)
  10. Geezer

    Geezer New Member

    Linksys WRT54G

    I was having similar frustrations at home: showing the network but not connected in Safari. What solved it for me was downloading new firmware for the router.
  11. debjax

    debjax New Member

    I had the same problem and went through resets, cycling the router and the phone and an hour on support with apple tech.

    Finally update the firmware on my linksys router, recycled it and the phone connected right away.
  12. jivasummo

    jivasummo New Member

    Fixed!

    I could see the signal but none of the apps could connect... so I went into Settings - Wi-Fi Networks then I turned it OFF, then ON again (the switch at the very top, the first one). I didn't see my network so I chose "Other..." reentered my network w/ WPA and now it works.
  13. BobTaylor31

    BobTaylor31 New Member

    ;-) PROBLEM SOLVED:
    I had the same problem with my wife's iPhone 4. My iPhone would connect, my daughter's would connect, our laptops and our XBOX live could connect, but for some reason her phone would not. I upgraded the firmware on my router and that fixed the problem. I also made sure we had the most current version of iTunes and the Apple OS as well. You'll want to go to your router's web site and download the most current version of firmware to your computer (I downloaded to my desktop). You then log in to your router from any of your computers at home with internet connection. For mine, once logged in to my router, there is a button called Router Upgrade, then I selected browse, then I went to desktop, selected the file I had saved to my computer, and then let it upgrade. While upgrading it disconnects all internet connections so don't freak out. It's only temporary (a few minutes). Once the upgrade was complete I went to connected devices and selected refresh. I didn't read anywhere that this was required, it was instinctual. Once I went to my wife's phone, it was now connected to wifi. PROBLEM SOLVED.

    My experience so far with Apple products is you'll likely find a solution to your problem by going to Google or to the Apple web site and trouble shooting the problem. I have not had all that much luck when on the phone with a Tech support person from Apple. I'm sure they are great people, but after spending over 6 hours back and forth on the phone and a trip to a local Apple store, I found a solution to my problem on Google. What was amazing is that the solution to my problem was never suggested by anyone in tech support at Apple and only at the very end of the conversation with a support person at the Apple store did they suggest a fix that I confirmed would work on the internet. Best of luck as you navigate your connection problems.
  14. rodeo9094

    rodeo9094 New Member

    hi guys, thought id sign up to share the wealth..
    luckily I fixed mine within the hour..
    after trying a few different ways I have solved the problem (well, mine!)

    all I did was press 'other' when connecting to wifi, changed security to 'wpa' (which is what my router is set to - you can check this by going to your routers home page, 192.168.0.1, this varies from router to router obvoiusly, but chances are itll be written on your router somewhere) and typed in my router ssid and password and it connected..

    bish bash bosh!
  15. Muhamad Lutfi

    Muhamad Lutfi New Member

    hi guys, I have the same problem..but tell u what...I've fixed it. in my case it is the WEP key problem. I chamged it
    to wpa2 , and now I can access the internet.worth a try. gud luck

Share This Page