iPhone doesn't charge anymore :(

Jan 4, 2009
1
0
0
#1
Hey everyone,

I've tried finding a topic from someone with the same or similar problem, but to no avail.

I have the 2G iPhone, bought in the USA a good few years ago. It has been jailbroken since day one with no issues.

The problem is, the phone doesn't want to charge at all since earlier this evening. I got the warning that the battery is low (20%), so I plugged it into the wall and it started flashing black then white over and over again. Then the sound disappeared and a message popped up that I can't make or receive calls and should restore the phone with iTunes. This all happened while it was plugged in charging (or trying to charge).

So I plugged it into my laptop, clicked on restore which seemed to be going well until a message popped up saying that an unknown error occurred and that the iPhone couldn't be restored. In the mean time I kept checking on the battery status, and it wasn't charging while plugged into the laptop either.

Since then, I've switched it off and just left it alone for 30 minutes. Then I plugged it into the wall again without switching it on and left it for another 30 minutes. I just picked the phone up to switch it on and it's burning hot! Tried switching it on again but it's frozen on the Apple logo. So I just switched it off, left it for another few minutes, tried to switch it on and it's still frozen on the Apple logo...


Any help on what to do or what the problem might be would be greatly appreciated :) Thank you.


Edit:
I should probably add that I've never even dropped the phone
 

Watcher

Zealot
Gold
Mar 29, 2009
1,785
30
48
Phoenix, AZ
#2
It's quite possible you've reached the end of the battery's lifespan. Either that or the flash drive. They do have a limit and I've always wondered what it was...