iPhone in recovery mode, trying to restore - Error 14

budsbava

Member
Bronze
Jan 8, 2008
46
0
6
#1
iPhone in recovery mode, trying to restore - Error 14

Hello all,

I need serious help...my iPhone went into recovery mode, couldnt get the screen ON...juss an symbol of connecting to iTunes is appearing.
when I try to connect it to iTunes it says the phone is in recover mode please restore...when I'm trying to restore its completing all the process and gives me error # 14. Tried this process 10 times but the same error continues...even I tried in different PC and Mac Book also...but the result is same.
iPhone is not jailborken nor unlocken. Its the regular 8gb one. Please help..will be waiting for all your suggestions.

Thanks in advance..!
 

iphun

Zealot
Gold
Mar 16, 2009
1,967
0
36
PA
#2
iPhone in recovery mode, trying to restore - Error 14

Hello all,

I need serious help...my iPhone went into recovery mode, couldnt get the screen ON...juss an symbol of connecting to iTunes is appearing.
when I try to connect it to iTunes it says the phone is in recover mode please restore...when I'm trying to restore its completing all the process and gives me error # 14. Tried this process 10 times but the same error continues...even I tried in different PC and Mac Book also...but the result is same.
iPhone is not jailborken nor unlocken. Its the regular 8gb one. Please help..will be waiting for all your suggestions.

Thanks in advance..!
Do you have 3.0 on your phone? Is it a 3g?
I looked at the Apple support website and I found this which is the same as your error http://discussions.apple.com/thread.jspa?threadID=1899499

If you are unable to restore it and don't have 3.0 on it you can take it to an Apple store and have a genius look at it, they can usually figure all that stuff out for you. Then if it comes down to where they can't fix it they should replace it if it's in warranty.
 

Adam1389

Member
Silver
Nov 20, 2008
588
1
18
Ilwaco, WA
#3
Recovery mode, error 14

Check this link, its for jailbroke phones, but it should solve the issue for you as well
 

budsbava

Member
Bronze
Jan 8, 2008
46
0
6
#4
Its a 2g...2.2version on my iPhone..
 

budsbava

Member
Bronze
Jan 8, 2008
46
0
6
#5
@ Adam..

Tried the link u given...no use...cant fix the problem...still the same.. :(