iPhone keeps changing time by itself

  1. AeroCare

    AeroCare Zealot
    Gold

    Joined:
    Jul 16, 2009
    Likes Received:
    25
    Ever since Sunday when Daylight Savings Time changed my phone has been changing time zones on its own. I keep entering Dallas USA and the correct time and a few hours later it's showing Chicago USA and 1 hour later. It's messing up my alarm clock more than anything but it's becoming very annoying.

    Is there a way to keep it from updating if it's the carrier who's doing this?
     
    #1
  2. Europa

    Europa Genius
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    3,886
    Check these settings:
    Settings > General > Date and Time > Set Automatically
    Settings > General > Location Services > On

    If they are already set like that and you're having problems, then you could toggle Set Automatically off.
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. alexjems41

    alexjems41 Guest

    I have also this type of problem so I set automatically off but also it keeps changing time by itself.What do i do?please help me
     
    #3
  5. AeroCare

    AeroCare Zealot
    Gold

    Joined:
    Jul 16, 2009
    Likes Received:
    25


    I found the problem. I DON'T HAVE the "Automatically" setting! It's not there after redsn0w JB.

    I thought it was Sunday when Daylight Savings Time changed but the problem must have started on Friday when I did the JB and I hadn't noticed it yet. I turned on Location Services so maybe it won't change me from Dallas to Chicago, we'll see today.
     
    #4
  6. Mickeylittle

    Mickeylittle Zealot
    Bronze

    Joined:
    Jan 16, 2009
    Likes Received:
    10
    I'm confused because it's the same time in Dallas and Chicago.
     
    #5
  7. Hawk

    Hawk Genius
    Gold

    Joined:
    Aug 2, 2007
    Likes Received:
    268
    They might be in the same time zone. And the next question would be "do they both observe daylight savings time?"
     
    #6
  8. AeroCare

    AeroCare Zealot
    Gold

    Joined:
    Jul 16, 2009
    Likes Received:
    25
    I put in Los Angeles and it took off 2 hours so I put Orlando and it added an hour. I'm just going to leave Chicago and set it with an hour less than what it's showing to see if it changes anything.
     
    #7
  9. Mickeylittle

    Mickeylittle Zealot
    Bronze

    Joined:
    Jan 16, 2009
    Likes Received:
    10
    Yes they both do so I have no clue why they would show an hour difference!
     
    #8
  10. Hawk

    Hawk Genius
    Gold

    Joined:
    Aug 2, 2007
    Likes Received:
    268
    Does your calendar show the correct date?
     
    #9
  11. AeroCare

    AeroCare Zealot
    Gold

    Joined:
    Jul 16, 2009
    Likes Received:
    25
    I was about to mention the calendar. Date is good but all apointments in Outlook 2007 are showing up 1 hour later on the iPhone than what is showing on the computer. This is hapenning on single and recurrent appointments. Everything is shifted 1 hour later. Appointment on laptop says 7:00 am but it's showing up at 8:00 am on phone. I even synced and told iTunes to replace the entire calendar on the phone and it still all shows up shifted 1 hour. WEIRD!
     
    #10
  12. Europa

    Europa Genius
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    3,886
    These suggestions might seem random but it worked for me when I was stuck in a predestination paradox.
    1. Remove and replace SIM.
    2. Reset Network settings.
    3. Fly through two time zones.
    4. Get Chick-fil-A to go and watch "A Benihana Christmas" Office episode.
     
    #11
  13. Napoleon PhoneApart

    Senior Moderator

    Joined:
    Jun 19, 2007
    Likes Received:
    3,318
    Well, you have steps 1 through 3 down...
     
    #12
  14. AeroCare

    AeroCare Zealot
    Gold

    Joined:
    Jul 16, 2009
    Likes Received:
    25
    I did 1, 2, and 3 today. 4 is going to be a little trickier to do.
     
    #13
  15. AeroCare

    AeroCare Zealot
    Gold

    Joined:
    Jul 16, 2009
    Likes Received:
    25
    I got it working ! The iPhone has two separate time zone settings. The one used for the entire iPhone is at Settings then General then Date and Time then Time Zone. I found another one at Settings then Mail, Contacts, Calendars then Time Zone Support. If you have Time Zone Support ON but in a different time zone than the other one then it all goes crazy.

    I also found out that Outlook 2007 has time zones in it for the Calendar too so I just changed everything to the same city and time zone and bingo ! All's good.... up to now.

    Hope this helps anyone out there with the same issue.
     
    #14

Share This Page