iPhone not checking for emails

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

seb481

New Member
Silver
Aug 3, 2007
774
1
0
San Diego
#1
I noticed since the last update my iPhone doesn't check for emails every 30 minutes as I set it up. It randomly checks emails or waits for me to ask it to. I rebooted the phone several times but it didn't do anything. Did anyone noticed that too?
 

sdge

New Member
Bronze
Jul 8, 2007
244
0
0
#3
I know. Yahoo almost never pushes my email and now the option to have it check every so often is no longer in settings... kinda blows a lot.
 

iPhone8801

New Member
Bronze
Sep 22, 2007
82
0
0
#4
Yeah, same problem. F ing sucks. Also, safari has an awesome habit of restarting itself. What's the deal. Seriously?! W t f
 

applecart

New Member
Bronze
Oct 13, 2007
39
0
0
miami, fl
#5
had the same problem. i deleted email profiles, turned on/off and then recreated profiles. now yahoo! mail push is working. might try that.

i could be wrong, but the option to set only shows when you have non-yahoo!, such as gmail or aol. if you only have yahoo! email accounts listed, the check mail settings options will not display. at least thats how my iPhone works.
 

ColsTiger

Zealot
Gold
Mar 8, 2007
5,856
2
38
Columbus, GA
#6
Yeah, same problem. F ing sucks. Also, safari has an awesome habit of restarting itself. What's the deal. Seriously?! W t f
Just turn your phone completely off and it will clear the cache. Most people only lock the phone and put it to sleep. If you'll shut it completely down about once a week, it won't do this.
 

termleech

Zealot
Gold
Sep 7, 2007
1,154
2
38
McPherson, KS
#7
I've had the exact same issue since the update and I think I've narrowed it down. From my best testing this will happen when you have Wifi turned on but aren't near a Wifi point. It then seems to get "hung up" and until you manually go in and check for email then it will start workin again. But if you go away from a Wifi point and keep Wifi on the problem with occur again. From everything I tested this will reproduce the problem every time and just turning off Wifi when not using it with a Wifi point works.
 

seb481

New Member
Silver
Aug 3, 2007
774
1
0
San Diego
#8
had the same problem. i deleted email profiles, turned on/off and then recreated profiles. now yahoo! mail push is working. might try that.

i could be wrong, but the option to set only shows when you have non-yahoo!, such as gmail or aol. if you only have yahoo! email accounts listed, the check mail settings options will not display. at least thats how my iPhone works.
I tried this and it didn't help :(
 

electoman

New Member
Bronze
Sep 20, 2007
127
0
0
Atlanta, GA
#9
I do the same thing with this iPhone that I have done for years with my PPC and Treo phones, start each day with a reset. I get all my emails and the yahoo push seems to be fairly consistent. I am sure that it is overkill with the iPhone but, it is a habit that seems to keep me from having troubles.
 

iphonenut

New Member
Bronze
May 17, 2007
373
0
0
#10
yeah, i've recently noticed the problem as well.

usually, the emails get pushed through...eventually. but lately, they're not coming through at all and then i get a bunch of emails at the end of the day.

From what I gather the "solutions" are:

1) delete and re-enter the account information

2) restart the computer everyday

3) turn off wi-fi when not in wi-fi area?

...i seriously hope Apple can address this in their next update. The email is kind of useless if you're not getting them at a reasonable time.
 

Joseph B

Member
Bronze
Sep 17, 2007
33
0
6
#11
Just for the record, I've had the same problem with my Gmail account since the 1.1.1 update. And for me, turning Wi-Fi off (when not near an accessible Wi-Fi hotspot) solved the problem.

I've also had the problem with Safari just "bumping" me back to the "Home" desktop half-way through a web page. That's only happened to me once since 1.1.1; and I found that turning the iPhone all the way off for a few minutes completely solved that problem.