iPhone not connecting to wi-fi (already read the other threads)

  1. TheMainEvent New Member

    Joined:
    Jul 22, 2007
    Likes Received:
    0
    ok well ever since ive had my iPhone i haven't been able to connect to my wi-fi network, although i have had no problem connecting to networks other than my own. like most others have said, it will show that i am connected yet when i try to open a web page, it will say that it "cannot connect to server". i read that changing the WEP key to hex or something like that works, but there is no option for changing that on my iPhone.

    i also tried reseting my router and iPhone with no luck. i don't know what else do do....if anyone could help me out here then that would be great. it sucks being stuck using edge when i have a wi-fi connection that works on all my other devices. thanks.
     
    #1
  2. eplantz Member Bronze

    Joined:
    Jul 1, 2007
    Likes Received:
    0

    http://www.anyiPhone.com/2007/06/30/iphone-wifi-tips/
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. TheMainEvent New Member

    Joined:
    Jul 22, 2007
    Likes Received:
    0
    i tried the things on that list and its still not working....if anyone else could give me some more advice it would be greatly appriciated.
     
    #3
  5. Tinman Evangelist Gold

    Joined:
    Jul 16, 2007
    Likes Received:
    184
    Since you've read all the other threads you already tried changing DNS IPs, right? You can't get to Google via 64.233.167.99?


    --
    Mike
     
    #4
  6. TheMainEvent New Member

    Joined:
    Jul 22, 2007
    Likes Received:
    0
    Actually I haven't tried that yet. Could you post a link i never read that thread.
     
    #5
  7. Tinman Evangelist Gold

    Joined:
    Jul 16, 2007
    Likes Received:
    184
    Well you need to verify it is a DNS issue. Can you get to Google using the above IP address?

    Either way the DNS workaround is merely overriding DHCP-supplied DNS IPs with either your ISP DNS, or public DNS IPs like these:
    208.67.222.222
    208.67.220.220

    In my case, and others I have read about, the DNS IP supplied by the router via DHCP was the router's IP (i.e., it will match gateway IP). While this should work, in some cases it doesn't work right with the iPhone, hence the DNS override workaround.

    But again, I wouldn't try that without first testing Google via IP.



    --
    Mike
     
    #6
  8. Hecubus New Member Bronze

    Joined:
    Jul 9, 2007
    Likes Received:
    0
    Okay, thanks for this information. I was able to get to google with the above address, but I'm not sure what I need to do now. I have a Belkin Wireless G router. Is there something I need to do within the router, or within my iPhone?

    Thanks much.

    EDIT: I actually tried what you had written in another forum post...


    1.) From the main screen go to Settings, and from Settings go to Wi-Fi.

    2.) The Wi-Fi network you are currently connected to will have a blue check next to it, over on the left. For that same WiFi network, tap the blue circle (with ">" inside) to get to more options.

    3.) Look at both the Router and DNS IP addresses. If they are the same, you might have a DNS issue, and continue on to step 4. If they are not the same you probably don't have a DNS issue, so only continue on if you have no other options.

    4.) Tap inside the DNS field, and the cursor will be positioned at the end. Delete everything there. Enter the following instead:
    208.67.222.222, 208.67.220.220

    5.) Tap Wi-Fi Networks to go back to exit that screen.

    6.) Press the Menu button to go back to the main screen and try Safari again.

    ...and it worked perfectly (at least for the time being--I suspect it may crap out on me again, but this has been the best solution so far.)

    The odd thing was, my router and dns IP number were not the same, and while I don't understand the the how and the why as to my wifi working suddenly after implementing the above suggestion, I guess I don't get why you said "Look at both the Router and DNS IP addresses. If they are the same, you might have a DNS issue." Of course, you said, "might" but I'm just curious since I know next to nothing on the subject. When would it be a dns issue if the numbers were different, such as mine were? Just trying to learn more.

    Regardless, your teachings have worked. Thank you, sir.
     
    #7
  9. kevywevy New Member

    Joined:
    Jul 27, 2007
    Likes Received:
    0
    Can't connect to secured wi-fi? Try this...

    This is how I fixed my network issue instantly.

    For many networks, I couldn't get my iPhone to connect -- this really bothered me because sometimes I could acces wifi and sometimes I couldn't. Open networks never seemed to be an issue, but security-enabled networks caused me a huge headache.

    Try this:
    1) On your iPhone, navigate to Settings > Wi-Fi
    2) Select the network you wish to connect with and clicked "Forget this Network" to start from scratch
    3) Navigate back to the main Wi-Fi menu
    4) Selected "Other..." to manually enter in my network name and password information
    5) After manually entering the network name and password information, you may be able to successfuly connect

    Worked for me! I didn't have to turn off my router or the wi-fi on my iPhone for this to work.
     
    #8
  10. Tinman Evangelist Gold

    Joined:
    Jul 16, 2007
    Likes Received:
    184
    Glad you made progress. And, yes, it could still be a DNS issue if the DNS and gateway (router) IPs are different. The important thing is that in some cases the iPhone just won't work right with router-supplied DNS IPs. I'm hoping that issue gets addressed in a future update.


    --
    Mike
     
    #9
  11. hillyhi11s New Member

    Joined:
    Jul 28, 2007
    Likes Received:
    0
    i to cant connect

    I have tried all the tricks from this forum and others. Basically what i have found is that nothing gets me to the WiFi bars on the phone until enter "Router" info in the phone. But, i enter what i think is the right number, and the bars come up, but actually i cant access the internet. Its like i am receiving a signal but cant access past the modem.

    I have a PC and a b/g westell router (from verizon). What am i doing wrong and how do i find the correct Router # to enter in the phone. I have connected both with regular WEP password and the HEX style. Thats not the problem. Oh, and when i do connect to the network no numbers come up automatically for the IP, Subnet, Router, and DNS.

    Please help.:(
     
    #10
  12. vrsc Member Bronze

    Joined:
    Jun 22, 2007
    Likes Received:
    0

    Thanks, this worked great! I jusrt recently put my wi-fi at password protection and was having huge issues! So please tell me, will I have to do this everytime I walk into my house or try to use it? Thanks!
     
    #11
  13. emx620 New Member Bronze

    Joined:
    Jul 13, 2007
    Likes Received:
    0

    I didn't have a password but it still worked for me. Thanks!
     
    #12
  14. skiz420 New Member Bronze

    Joined:
    Jul 28, 2007
    Likes Received:
    1
    have you tryed to change the security setting on the router to WPA personal or using the WEP hex code insted...?
     
    #13
  15. kdawg New Member

    Joined:
    Sep 21, 2007
    Likes Received:
    0
    Forget Network Button

    I go to setting wi-fi and networks show up where is the "Forget Network Button" can't find it as describe above.
     
    #14
  16. musokestrain New Member

    Joined:
    Sep 28, 2007
    Likes Received:
    0
    Hey Hill,
    I know it's of no help - but I have exactly the same problem as you. The iPhone somehow is not receiving or processing the DHCP lease - hence you never get the IP address information. The WiFi is a bit scatterbrain as well - it may be a fault in the phone - take it back for a replacement maybe?
    musokestrain
     
    #15
  17. usman New Member

    Joined:
    Jul 2, 2009
    Likes Received:
    0
    hi guys i had the same problem my iPhone found my router and connected to it but was unable to open a site although it worked fine with my laptop..and all security was disabled.....then i put wep security and chose the 64bit ACsomething setting other than the hexadecimal....my iPhone found the ntwork but the same problem remained so in the end after reading numerous threads from various sites i gave up on it...one day out of coincidence i turned my wifi on and rather than choosing my connection i clicked on other i selected the security put the name of my network and the code...and IT WORKED i don't know if this helps u guys or not just tryin to help and i didn't put any special sttings in my router as i don't know much abt networking and stuff and u would have to forget your existing network first before choosing other...

    usman hope it helps
     
    #16
  18. usman New Member

    Joined:
    Jul 2, 2009
    Likes Received:
    0
    if this works note doen your ip address other things from iPhone wifi chosen network it stopped wrking the next time i tried but thankfully i remembered the ip address and chose static and put the ip address from when it worked let statc be chosen......

    it might seem like a stupid idea but it worked for me hopefully it might work for u...keep on tryin until it works how i have described above

    please reply if it works
     
    #17

Share This Page