iPhone Outlook email issues

Discussion in 'iOS Software' started by jfleming01, Apr 29, 2009.

  1. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    I'm new, didn't see this problem on threads. iPhone only gets emails from outlook 03 when Outlook is up and running on my work computer. I sync iPhone at home, but I have work email exchange set up. Yahoo and AOL accts work fine. Is there a setting in my work Outlook I need to change. BTW, calendar events entered on work outlook only show up on the iPhone when I clear the offline items (in folder/sharing/general tab) and relaunch outlook. Thanks
     
  2. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    I have the same setup. I use activesync with my work (Exchange) but sync my iPhone with the home computer.

    That sounds like a really weird problem. Mainly because in a true exchange environment your Outlook or iPhone are just clients and they both pull from your work's server. So it shouldn't matter what's up or not.

    Let me ask you this... when you are noticing that you ARE receiving emails, does it just so happen that you're on wifi? When your Outlook is open and your emails come in are you normally at work?
     
  3. Hawk

    Hawk Genius
    Gold

    Joined:
    Aug 2, 2007
    Likes Received:
    241
    It sounds to me like your Exchange server is not setup for mobile support. Have you or anyone else in your office used Mobile support (on a different phone) with that Exchange server?
    I am just trying to make sure that we are both clear about what the server is setup for. In the email program on the phone, you have to make sure that you are putting in the correct information under the exchange setup. Your exchange server has to be enabled to be access from outside the domain, and have the capabilities to "push" new mail, contacts, and calendar events to your mobile device. (you can choose one or any combination of the 3)
    If you are syncing at home, are you syncing all your contacts, calendars and email there?
    Your problem, if I am understanding you correctly sounds like one of 2 things are happening.
    1)your work email server is not setup to push anything to you through "active Sync"
    2) your email/calendars/(contacts?) are setup incorrectly for your work accounts.
     
  4. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    Hawk is probably on to something there.

    I totally skipped over the part about the offline content folder. I'm not 100% on what that folder is, is it because you don't have persistent connection with your exchange server or is it part of some cached .ost?

    Are you guys using Outlook Web Access (able to access Outlook via a web browser)
     
  5. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    Thanks for the replies. First, (for PapaST) I have WiFi off, and I get the emails instantly (no matter where i am) as long as Outlook is up. Second (Hawk) there are people here using Blackberries and getting the emails. Outlook exchange on the phone is set up to the server, and I have no problem accessing my emails Outlook Web Access (whether or not Outlook is running on my work computer). I've syncd the phone to my home computer iTunes to get songs and apps, but I have done nothing with Outlook there.
     
  6. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    Hmmm... that's a pretty strange problem. BB will pull emails either through a redirector, BIS or BES so it doesn't work on the same lines as iPhone and ActiveSync.

    But the fact you get any emails at all on your phone suggests you definitely get a connection with the server. But only when Outlook is up sounds odd. With Wifi off that sort of kills what I thought the issue might have been. I wonder if Outlook having to be open suggests some type of redirection of your emails.

    When you compare your OWA web address which should be something like http://random.server.com/exchange is your server address on your iPhone set to random.server.com?

    Just so we're on the same page, you did setup that account using Microsoft Exchange ActiveSync and not IMAP correct?
     
  7. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    Thanks again. OWA address and server address are like you suggested. As far as set up, I added the account on the Microsoft Exchange page on the phone, and put in the exchange info, user name and password. Didn't enter a domain, but when I go back to that account info screen it has populated the domain name and changed the user name. IT people here checked and ActiveSync is enabled for all users.
     
  8. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    That's pretty odd. Try checking your accounts in Outlook. See if your Outlook is setup to run a POP account AND an Exchange account. That is a long shot but at this point without seeing the setup it's hard to diagnose.
     
  9. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    There is only 1 email account listed (microsoft exchange server) if I hit add POP3, IMap etc come up as options.

    One more thing, when I create the account on the iPhone it said verification failed, and then I accept that and proceed on. Someone here thought that might have something to do with why Outlook has to ne open for the mail to get to the iPhone.
     
  10. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    Normally when I see that it's because SSL is enabled. After accepting the account I go back in and disable SSL. Everything works fine from there. You might try the account with then without SSL to see how it functions.
     
  11. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    I had to disable SSL to get it to work. Arrgghhh.
    Love the phone though. Thanks
     
  12. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    what I meant that was that I had to do that originally. Haven't figured it out yet. Thanks
     
  13. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    Hmmm. Well again without seeing it I guess I would try crazy stuff like... what would happen if you deleted your Outlook account/profile (not your user account on the server)? See if anything changes, if not recreate it. If your account is on exchange then it shouldn't be more than a couple of clicks to re-setup your account.

    Know anyone else with an iPhone? Have them setup your account on their phone and see what happens. Anything that might give a clue as to why this happens the way it does.
     
  14. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    Read somewhere that it might have something to do with the Norton antivirus settings. Does this make any sense?
     
  15. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    I'm guessing you mean Norton AV on your computer? That could be a possibility. I've seen NAV cause issues when trying to send out emails but I don't think that would effect your iPhone.

    I touched on this before, the thing that really has me scratching my head is the fact that to get any emails your phone and computer pulls it down from the server. So regardless if you have 1 Outlook, 100 Outlooks or no Outlooks setup to get emails, your iPhone is going to the server, not your Outlook. So if your Outlook has to be open to get emails this tells me:

    1. one theory I had was you had a POP account (along with exchange) and your POP was pulling down emails then importing them to your exchange profile which enabled you to finally get your emails. But you've already checked and that's not the case.
    2. the fact that Outlook has to be open is coinciding with some other event that is makes us think that Outlook must be open but is actually something else.


    Is your Exchange hosted onsite? Or is it hosted with another provider?

    You're definitely not the first... I found this article and the guy is having the exact same problem. http://discussions.apple.com/thread.jspa?messageID=8569182

    Any chance you guys were in a Groupwise environment then migrated to Exchange? I've seen some lingering Groupwise policies that can cause havoc on Exchange (somehow).

    If your exchange is hosted elsewhere maybe there's a chance they have a weird policy in place that inhibits the iPhone unless Outlook is open. For instance your account might not be active unless it has a session connected. Try closing your outlook, open an OWA session and then see if you're getting your emails.
     
  16. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    Just for kicks, try disabling NAV on your computer to see if it works.
     
  17. PapaST

    PapaST Member
    Bronze

    Joined:
    Sep 10, 2007
    Likes Received:
    6
    You mentioned not being able to verify the account when you set it up. Can you try emailing the certificate to an email account you can get on your phone and then open the attachment in safari. From there it will prompt you to install.
     
  18. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
  19. jfleming01

    jfleming01 Member
    Bronze

    Joined:
    Apr 29, 2009
    Likes Received:
    7
    Same thing happens when Outlook is closed and an OWA session is up. OWA says I have new mail, but until I click on it and it shows up in the inbox, the iPhone never sees it. If I open Outlook, it shows up on the phone as soon as Outlook downloads it, even if I haven't opened it in OWA. Bizarre.
     
  20. Cark

    Cark New Member

    Joined:
    Jan 27, 2012
    Likes Received:
    0
    I know this is a old post, but I thought I would post a reply on what fixed this issue for me.

    It has to do with a setting in the Exchange server's registry, called proactive scanning. When it is disabled, exchange wont scan the email automatically upon receiving it (and as such, wont pass the email to Activesync/iPhone/Android/etc) until it has been accessed with either Outlook or OWA.

    There is a guide on how to enable Proactive Scanning on Exchange here: http://www.networkinghowtos.com/howto/activesync-device-not-receiving-new-emails-unless-outlook-open/
     

Share This Page