iPhone restarts when attempting to play recorded video

eugchen23

Member
Bronze
Jul 22, 2010
186
0
16
#1
i recorded a video of my daughter through the camcorder function, and when i try and replay it, the iPhone automatically reboots and shows the Apple logo. i cant seem to play any of the recorded videos. any ideas how to fix this or find out what the issue is?

thanks
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
701
113
#2
Have you tried connecting your iPhone to your computer? You can backup and sync your video's on to your computer.
 

Sharunda

Genius
Gold
Jun 16, 2008
4,987
1,085
113
One Horse Town, New Jersey
#3
Definitely back up your phone first but, have you done a hard restart? Sometimes when things get hokey, you can try this last resort before doing a compete Restore of the iPhone.

In case you have never done this before, to do a hard restart, you hold down the on switch on the top right and the home button until you see the Apple Logo. This will restart your phone fresh and should "quick fix" any weird problem you have with the phone.
 

eugchen23

Member
Bronze
Jul 22, 2010
186
0
16
#4
yes, tried a hard reset with no luck. i can backup and sync videos to computer, but i want to watch them on teh phone.
 

Bennyboy

Genius
Platinum
Jul 21, 2010
14,017
1,756
113
PA
#5
Seems like you gonna need to restore if you ask me, unfortunately if the hard reset didn't work it sounds like a major software glitch.
good luck.
 

Sharunda

Genius
Gold
Jun 16, 2008
4,987
1,085
113
One Horse Town, New Jersey
#6
Well, sorry the hard reset didn't do the trick.

I was going to suggest that you call Apple, but they will tell you to do a complete Restore. I understand you want to access the videos on your phone and of course when you do a Restore everything will be gone, but if you put your last back up back on the phone everything, maybe including the glitch, will be put back on the phone.

It's worth a shot though. Back up your current info if you haven't already and then do a Restore and put your back up back on the phone and see if the kinks were worked out.
 

eugchen23

Member
Bronze
Jul 22, 2010
186
0
16
#7
im pretty sure it is cydia glitch, but not sure how to figure it out what it is...any ideas?

the video plays fine in safe mode.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#8
im pretty sure it is cydia glitch, but not sure how to figure it out what it is...any ideas?

the video plays fine in safe mode.
Moved to iPhone Jailbreak.

Ah, now we're getting somewhere. I'm almost certain this is related to your jailbreak. Do you have any jailbreak photo/video apps installed? They can conflict with the stock photo app and cause problems. You can run Crash Reporter (Cydia app) to try to determine which app is causing the problem or you can just uninstall Cydia apps one at a time and test to see if the problem is resolved. I'd start with photo/video apps as they are the most likely culprit.
 

eugchen23

Member
Bronze
Jul 22, 2010
186
0
16
#9
thanks, i figured out my errors were due to MUSIC INFO--a cydia tweak
thanks!