iPhone showing old emails instead of recent

jackz5o

New Member
Bronze
Jul 14, 2008
150
0
0
New Jersey
#1
For some reason my iPhone 3G is showing the first 100 emails I have ever received instead of recent emails on my Yahoo account. However, pushed emails seem to stay on top where it is suppose to be.

I have tried restarting my phone and also tried setting up Yahoo email again but I still have the same problem.

Anybody got a solution or some other ideas?

Thanks
 

jmido8

New Member
Nov 8, 2008
11
0
0
#3
There is probably a setting in there that lets you view emails by the most recent. Try searching for that.
 

jackz5o

New Member
Bronze
Jul 14, 2008
150
0
0
New Jersey
#4
I tried searching for that but the only sorting options are by name, not receive date.
 

smknSRT8

Zealot
Gold
Oct 13, 2007
1,325
1
38
#5
What happens on you computer when you access your email?
 

smknSRT8

Zealot
Gold
Oct 13, 2007
1,325
1
38
#6
I tried searching for that but the only sorting options are by name, not receive date.
Are you talking about on the Yahoo! mail or on the iPhone. I went to Settings>Mail, Contacts, Calender>Show. Then select how many you want to show.
That is bizarre though. My Yahoo! account is working fine for me.
 

jackz5o

New Member
Bronze
Jul 14, 2008
150
0
0
New Jersey
#7
it's only on my iPhone, Yahoo mail on my computer works perfectly fine.

I'm not talking about how many messages it shows, but the order. It's showing emails from 2 years ago where it's suppose to be showing recent emails.
 

wahine220

New Member
Nov 11, 2008
1
0
0
#8
I am having this same problem with my paid Hotmail account. Very frustrating. The setting is for the most recent messages; not the oldest messages.