iPhone Shuts down and goes into safe mode - Help!

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

EverythingApple

Evangelist
Gold
Jul 28, 2010
3,862
225
63
North Jersey
#1
At least once a day, but has happened to me twice already today, my iPhone 4 shuts down and goes into safe mode when using the native Apple Mail app. Any ideas what the culprit could be? I haven't installed any new apps or Cydia apps. I'm backing up my iPhone (using PKGBackup and SugarSync) and contemplating doing a restore and re-jailbreaking, but wanted some suggestions before I take on that task.
 

chazm

Contributor
Silver
May 1, 2008
729
40
28
#2
Just the fact that you are JB makes me believe it's that. Im nearly certain it is that. Something is interfering with the mail app
 

EverythingApple

Evangelist
Gold
Jul 28, 2010
3,862
225
63
North Jersey
#6
I also found this, and am in the process of doing this too:


See also these tips from our Safe Mode fixing guide:
If the Springboard crash keeps happening, one or more of your installed tweaks is probably incompatible with your device's version of iOS. Open up Cydia, go to Manage -> Packages, and check the descriptions of each of your installed tweaks to try to find out whether they're compatible with your version of iOS. If one isn't, it's probably the reason for your crash, so uninstall it using Cydia. (Also check your packages to make sure they're all from legitimate sources such as BigBoss, Cydia/Telesphoreo, ModMyi, and ZodTTD/MacCiti; pirated packages frequently cause problems.)

If you have SBSettings installed, you can tap the "More" button and use its "Mobile Substrate Add-ons" feature to temporarily disable some of your tweaks so that you can isolate which one is causing the problem. (Disable some of them, respring, and see if Springboard crashes. If Springboard still crashes, disable some more. If the problem seems fixed, enable some of them. Continue this process until you isolate which one is the cause of the problem.) This is a little faster than uninstalling and reinstalling tweaks using Cydia, but if you use this method, you must make sure to re-enable tweaks before uninstalling them.​
Disabling tweaks using that method should be enough to diagnose the problem. Uninstalling is more foolproof, but it's also more time-consuming.
 

EverythingApple

Evangelist
Gold
Jul 28, 2010
3,862
225
63
North Jersey
#9
Nice!
Thought my suggestion was a shot in the dark, but you had said no new Cydia tweaks installed....
I had nothing new. It just started happening. So, I disabled MailSureSend as described above and it seemed to work. MSS says its iOS 5+ compatible but it does seem to have a bug. I'm attaching the CrashReporter Report & the MSS screenshot as a FYI.
 

Attachments

Dec 10, 2009
2,589
1,337
113
51
Clarksburg, WV
#13
Generate another crash report and see if it gives you a clue...
Do you have any other tweaks that have anything to do with mail? I see you removed the trial version of the App in question, did you install the paid?
 

EverythingApple

Evangelist
Gold
Jul 28, 2010
3,862
225
63
North Jersey
#14
Generate another crash report and see if it gives you a clue...
Do you have any other tweaks that have anything to do with mail? I see you removed the trial version of the App in question, did you install the paid?
Yes, I installed MailEnhancerPro paid version. MSS is still disabled. I'll disable MEP and see if that does it. I like MEP in that I can have a separate signature for each mail account.