iPhone standard system font changed mysteriously

h.s

New Member
Oct 14, 2008
17
0
0
#1
Hi everybody,

after the latest app update through Cydia, my standard font has been mysteriously changed. It's no longer Helvetica but looks like Courier / New (some typewriter-like fixed-with font).

This affects the whole system: App names under the logos, Safari standard font, calendar, texting, you name it.

How can I change this back? I'm aware of programs like FontSwap (which I installed but never used) and the Winterboard font pack - but I don't want to add to the confusion for my iPhone and would rather like to reverse the error the right way (tweaking some plist or whatever).

The Cydia update after which the font was changed contained the latest MobileSubstrate, Winterboard and MPlayer updates, what makes Winterboard my main suspect in this.

Help is appreciated!
hs

3G, FW 2.2 (Baseband 02.11.07), using a SIM proxy
 

kenneth

Zealot
Gold
Aug 19, 2008
1,465
0
36
Texas
#2
can you post a screenshot of the "new" font?
 

kenneth

Zealot
Gold
Aug 19, 2008
1,465
0
36
Texas
#4
weird... im sure there is something that is changing it. I like the font though.
 

bnlstr

New Member
Jan 4, 2009
1
0
0
#5
How to fix!

Hi everybody,

after the latest app update through Cydia, my standard font has been mysteriously changed. It's no longer Helvetica but looks like Courier / New (some typewriter-like fixed-with font).

This affects the whole system: App names under the logos, Safari standard font, calendar, texting, you name it.

How can I change this back? I'm aware of programs like FontSwap (which I installed but never used) and the Winterboard font pack - but I don't want to add to the confusion for my iPhone and would rather like to reverse the error the right way (tweaking some plist or whatever).

The Cydia update after which the font was changed contained the latest MobileSubstrate, Winterboard and MPlayer updates, what makes Winterboard my main suspect in this.

Help is appreciated!
hs

3G, FW 2.2 (Baseband 02.11.07), using a SIM proxy
Hey bud,

Same thing happened to me. You need to edit the info.plist file under the
/saurik.theme/ folder. You can use total commander 7 to search for this folder. Mine was in \private\var\stash\themes.coEri5\Saurik.theme\
Theres two entries of "font types", edit the "courier new" one out and replace with helvetica. Hope this helps.

Here's the thread I found help on.
http://www.modmyi.com/forums/cydia-...package-update-caused-system-font-change.html

*afterwards.. your fontswap will correctly change system fonts
 

h.s

New Member
Oct 14, 2008
17
0
0
#6
Hey bud,

Same thing happened to me. You need to edit the info.plist file under the
/saurik.theme/ folder. You can use total commander 7 to search for this folder. Mine was in \private\var\stash\themes.coEri5\Saurik.theme\
Theres two entries of "font types", edit the "courier new" one out and replace with helvetica. Hope this helps.

Here's the thread I found help on.
http://www.modmyi.com/forums/cydia-...package-update-caused-system-font-change.html

*afterwards.. your fontswap will correctly change system fonts

Thanks mate, that did the trick! Owe you one.
 

kenneth

Zealot
Gold
Aug 19, 2008
1,465
0
36
Texas
#8
^^^
As in something that could be changed or turned off. Wow good job you made me a captian of the obvious.
 

kenneth

Zealot
Gold
Aug 19, 2008
1,465
0
36
Texas
#9
^^^
thats what I thought. LOL.
 

PepeRB29

New Member
Mar 21, 2008
1,500
0
0
8 mile
#10
could install fontswap and change it that way too
 

Newbies

New Member
Oct 21, 2008
18
0
0
#11
Hey bud,

Same thing happened to me. You need to edit the info.plist file under the
/saurik.theme/ folder. You can use total commander 7 to search for this folder. Mine was in \private\var\stash\themes.coEri5\Saurik.theme\
Theres two entries of "font types", edit the "courier new" one out and replace with helvetica. Hope this helps.

Here's the thread I found help on.
http://www.modmyi.com/forums/cydia-...package-update-caused-system-font-change.html

*afterwards.. your fontswap will correctly change system fonts
Thanks a lot bnlstr, h.s.
I got the same problem with h.s. I did fix it follow your instruction. Thanks again.