iPhone still taking FOREVER to back up?

Ace4261991

New Member
Silver
Jun 18, 2007
530
0
0
#1
so before 2.0.1 my iPhone would take long to back up (maybe 30 mins) but now after its takes over 1 hour. this cant be right. somone mentioned before that it might be a corrupt backup thats causing this and to delete the back up i usually use and re back up so i did that the other day and it took about 2 hours and now im backing up again and its been about 30 mins and its only about 10% done. i do have about 40 extra apps from the app store idk how much that effects it.
anyone else have this problem if so or not let me know how long yours takes and how many apps you have
 
Jul 16, 2008
1,592
1
38
Colorado
#2
I just looked at iTunes to see how many apps I currently have installed: 37. I then tried to sync but no changes were made so I downloaded a free app because I knew before it would sync again it would create a back up. I took out my v1 iPhone and used it's stop watch to see exactly how long it takes (I've been saying it's generally between 1-3 minutes). Sure enough, it took 2 minutes and 13 seconds to be exact.

There's obviously something wrong with your backup file. I can tell you a few things that I've done tomorrow. It's been 3 hours since your post and it's almost 1:30 am here now... I need some rest.
 
Jul 16, 2008
1,592
1
38
Colorado
#3
OK man I didn't want to leave you hanging so I had to find a post which should benefit you greatly. Read the whole thread, it's currently only 6 or so posts long. Then click the link that John (aka Lincoln) provided to Swagger and follow that. Chances are when you set up your phone you gave permission to send diagnostics to Apple.

Here's the thread.

Good luck and good night!
 
Last edited by a moderator:

Ace4261991

New Member
Silver
Jun 18, 2007
530
0
0
#4
alright ill check it out thanks
 

Ace4261991

New Member
Silver
Jun 18, 2007
530
0
0
#5
well it worked! thank you sooo much man i tried it then did a back up and it only took about 6 mins. and i have 55 extra apps lol. man i must havbe spent over 4 hours tonight just backing up my iPhone bcuase the first time i backed up it finished but when i looked in pefrences it wasn't listed under the synced section it just showed a backup from a couple weeks ago so i had to do another back up and then it worked another couple hours later. thanks again! time to get some sleep
 

metapin

New Member
Aug 11, 2008
10
0
0
#6
The friend of mine had such troubles. almost the same reason. will send him link on this thread.
 
Jul 16, 2008
1,592
1
38
Colorado
#7
well it worked! thank you sooo much man i tried it then did a back up and it only took about 6 mins. and i have 55 extra apps lol. man i must havbe spent over 4 hours tonight just backing up my iPhone bcuase the first time i backed up it finished but when i looked in pefrences it wasn't listed under the synced section it just showed a backup from a couple weeks ago so i had to do another back up and then it worked another couple hours later. thanks again! time to get some sleep
You're welcome! I've been somewhat puzzled why some people are struggling with the backup process and, yet some of us don't have an issue at all. When I first read John's post, I knew I had already set my phone up like that from day one. I also believe the corrupt files issue is equally to blame. It appears to be a combination of those two things that affect the backup process the most.
Glad it worked for you. Now next time it begins the backup process, by all means, let it do it's job. The X is not your friend. ;)