iPhone unable to join the network message

Discussion in 'iPhone' started by hnm, Aug 12, 2008.

  1. hnm

    hnm New Member

    hi,

    i have an iPhone 8gb with rogers. whenever i go to settings--> wifi
    and choose my network under "choose a network list" , the iPhone gives me pop up saying "unable to join the network". i have tried this with and without an aspi/ wep hex password/ wpa , and without a password yet i still get the same message.

    i have also tried reseting my network settings and also a hard reset yet same message pops up.

    i have a smc 7004vwbr router. my laptop and the pc connects flawlessly with it. its just the iPhone. can some one please help me.[FONT=Arial, Helvetica, sans-serif][/FONT]
  2. splogue

    splogue New Member

    Unable to join the network

    After banging my head against this problem for two straight months, I finally found a solution.

    My network uses WPA encryption, with AES key and a Linksys router. I tried setting my phone to a static address, disabling mixed-mode network support, changing channels, disabling channel expansion -- nothing worked. My wife's phone can't connect either, so I knew it was a network configuration problem. I came very close to buying a new router from a different brand.

    Finally, today, I tried disabling "WPA personal" while leaving "WPA2 personal" enabled. And it worked. First try. Both phones.

    I was never able to find anyone on the net who had this problem and resolved it, so I'm posting this in a few forums to help out others searching for the solution.

    Sean
  3. Avatar

    Sponsored Advertisement

  4. dmclenna

    dmclenna New Member

    Hey just a quicky tip here. Most if not all "Linksys" passwords are "admin", unless of course you haven't changed it yourself.
  5. wcnel

    wcnel New Member

    Now able to connect to the network

    Brought home my new iPod Touch, but even though it would recognize my home wireless network, it would not join the network. My router uses WPA2 security with a password, but every time I CAREFULLY entered the password it was rejected. If I shut off security in my router, I could connect, but as soon as I returned to the security settings I could no longer connect. Here's the fix: I simply changed the password/key for my security setting in the router, and then the Touch would connect. Then I changed the password back to what it had been,and the Touch connects again. All good now.
  6. TimMaher

    TimMaher New Member

    This is driving me mad. I've re-built the phone, re-built the router, used a different router, used WEP, WPA & WPA-2, changed the passphrase, gone out for a beer; nothing works. Agghhh!

    Anybody know how to get this on front of somebody important at Apple?
  7. splogue

    splogue New Member

    I eventually gave up and bought a refurbished Apple Airport Express. I connected it to my router and use it just for the iPhones. Worked the first try and has been going strong ever since.

    Sean
  8. TimMaher

    TimMaher New Member

    Did you also go out for the beer?

    Hi Chris,

    Anyhow,

    I've just posted to a couple of other forums, including my mobile provider, so we'll see if anything wakes up. I don't think that this prob. will go away without a bit of a firmware fiddle from Apple.

    Regs

    Tim
  9. TimMaher

    TimMaher New Member

    Only that was Sean....

    I must have had too many beers.
  10. navr

    navr New Member

    resolution

    go to your Linksys router url e.g. 192.168.1.1

    login using username and password phrase


    go to Wireless and then Wireless Security

    On that page you'll see WPA pre-shared key if WPA personal was used for protection. This key will be a long string of alphanumerics

    enter this string exactly as a password on your iPhone Join network screen

    and Voila!:)
  11. TimMaher

    TimMaher New Member

    It was the antenna

    Thanks Sean,

    Good reply but much too sophisticated and I'd done all of that already.

    Anyhow, mosied into the Genius bar for a different issue and managed to blag a spot at the iPhone bar. They diagnosed a faulty antenna and replaced the phone. Everything now works perfectly on original configuration although I did have to reset the WPA key to get it going.

    Pity the answer was so straightforward. :eek:k:eek:k

    Regs

    Tim
  12. stephann3

    stephann3 New Member

    Thanks navr,

    My linksys router decided to stroke out last night. When we woke up this morning our iPhone and touch both picked up the wifi but it was broadcasting unregistered and without security. I reconfigured the router with previous UN and PW. Everything checked out ok except I was unable to join my own network. I tried everything. Rebooted and reset everything. Last ditch effort... using security key as password. Success! I don't know what happened to the router, or why it will no longer allow me to join using the password and I don't even care. Thank you for the most obvious solution! :)
  13. Matthew G. Richter

    Matthew G. Richter New Member

    The solution that worked for me was:
    1) Go to your Mac computer>Airport Utilities>Access>click the "+" button on lower right of screen>type in your phone's Wi-Fi Address>click Update
    2) To find your phone's Wi-Fi Address go to your iPhone>Settings>General>About>scroll down to "Wi-Fi Address"

    This solved the problem for both my 2G and 3GS phones. I now can use a password to access the network, and both my phones and my Macbook all connect no problem.
  14. carllcope

    carllcope New Member

    Network not "Known"

    I found this thread searching for iPhone connection problems. While my problem was some different, it does match some of the solutions.

    I have a Linksys wrt54g wireless router configured with WPA-Personal2, AES, the SSID is not broadcast. My iPhone, as well as all guests and visitors (once I entered the SSID and password) connected and all was well. Until I reset my iPhone to factory settings.

    After that, my iPhone would connect, but it would not remember my network. Every time I had to reenter the SSID and password.

    After reading some of these posts, I decided to make some changes to the router. I made many changes, but here is what I believe finally solved my problem.

    1. On the router I enabled broadcast. Saved settings.
    2. On my iPhone I connected to the router (which the worked as I was broadcasting the SSID).
    3. On the router, I changed my SSID. Saved settings.
    4. On my iPhone, I connected to the new SSID. The old SSID was still visible, maybe because I did these changes in quick succession. I selected the old SSID and told the iPhone to forget the old network.
    5. On my router, I changed back to my original SSID. (I didn't want to have to reconfigure all other wireless devices.)
    6. On my iPhone, I connected to my original SSID.
    7. On my router, I disabled SSID broadcast.
    8. And my iPhone now remembers the network.
    While I gave all the steps above, I am wondering if the solution was simply to change the SSID. An earlier post was able to solve problems by changing the password and then going back to the original.

    Hope this is helpful.
  15. surcal

    surcal New Member

    Solved - Solved -Solved
    I held my iPhone touching the antenna of WIFI router, it connected to the router. I was able to use the internet in this position only. Moving away from router's antenna, internet does not works. At leaset now I can do some very urgent works on iPhone without GPRS connection.
  16. surcal

    surcal New Member

    Solved - Solved -Solved
    I held my iPhone touching the antenna of WIFI router, it connected to the router. I was able to use the internet in this position only. Moving away from router's antenna, internet does not works. At leaset now I can do some very urgent works on iPhone without GPRS connection.
  17. surcal

    surcal New Member

    I was not able to use my wifi for last six months.
  18. surcal

    surcal New Member

  19. ivanglinyany

    ivanglinyany New Member

    i have been having the same problem, all i did was go into the the settings, then wifi and when the network popped up i went into the settings of it by hitting the blue arrow on the right, then i scrolled down to HTTP proxy and it was on the OFF setting, Switching it to AUTO solved my connection problems.
  20. charlieyoga

    charlieyoga New Member

    My iPhone 4s also was unable to join the network. Under the linksys router tabs wireless -> wireless security I tried moving wpa2 personal to wpa personal but that required the network to go back to 801G so I didn't do that. So then I switched the encryption to AES from TKIP or AES and life was good once again. Thanks Sean you pointed me in the right direction!

Share This Page