iPhone WiFi problem, but iPod touch is ok?

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

catagory5

New Member
Bronze
Jul 23, 2007
44
0
0
#1
Ok I have a iPhone and an Ipod Touch. Oh and also a Buffalo Router. Problem is that the Touch will log on with Wifi but the iPhone will not. I have reset the network settings, made sure the password is being put in correctly, restored the iPhone, etc, etc......My laptop works fine, my Imac works fine, just not the iPhone. Oh and the weird thing is that at the Apple store my iPhone will do WiFi, just not at my house. Is there some kind of a limit to how many IP's my Router will address? Or could it be something else?

Thanks
 

el padrino

New Member
Sep 28, 2007
25
0
0
#2
Does your password have any special characters? You can disable the password and see if the iPhone connects correctly. Then enable the password again...preferably without special characters.
 

sammydee

New Member
Sep 25, 2007
4
0
0
#4
For me, my WEP key problems that I had with 1.0.2 on the iPhone are all fixed on 1.1.1. Since the Touch started out with 1.1 perhaps that explains why you see problems with the iPhone but not the Touch. You might try upgrading the iPhone to 1.1.1.
 

catagory5

New Member
Bronze
Jul 23, 2007
44
0
0
#5
Yeah I don't have any weird caracters. there is only letters and two numbers. Nothing fancy. I am totally up to date on the updates. Weird thing that happens is my Wifi will work at the Apple store or at other public places. It won't work at home though and all my other wireless connections will work, including my Touch. I've contacted Apple about 6 times but it seems they always skirt around the issue and don't really have an answer. Oh well.........
 

arugula

New Member
Oct 9, 2007
1
0
0
#6
I Have The Same Exact Problem!

Ok I have a iPhone and an Ipod Touch. Oh and also a Buffalo Router. Problem is that the Touch will log on with Wifi but the iPhone will not. I have reset the network settings, made sure the password is being put in correctly, restored the iPhone, etc, etc......My laptop works fine, my Imac works fine, just not the iPhone. Oh and the weird thing is that at the Apple store my iPhone will do WiFi, just not at my house. Is there some kind of a limit to how many IP's my Router will address? Or could it be something else?

Thanks
I have an iPhone which I recently upgraded to 1.1.1. I also have a Buffalo Router. Ever since I tried to log on to the iTunes Wifi store via my iPhone while I was logged on at the same time with my Powerbook, I have been unable to connect via wifi from my iPhone.

When I try to connect via wifi, I can see that my network has full signal. Then the iPhone will tell me that I am connected and the wifi symbol appears at the top left hand corner on the iPhone screen. But as soon as I exit the settings menu (or as soon as I exit and click on Safari or iTunes) the wifi symbol disappears and turns into the Edge symbol.

Anyone have a clue as to what's going on? I've tried resetting my laptop/router/iPhone, but nothing seems to do the trick.
 

alijahed

New Member
Oct 9, 2007
2
0
0
#7
Same Here !

Me and my friend both had this problem on our iPhones , but a lil different . when ever we searched for wifi nothing showed up but when we restarted the phone for the first 10-30 minutes we were connected then the connection was lost. my friend upgraded to 1.1.1 since he was on AT&T and now his iPhone works perfectly but mine is unlocked and that wont do it ! :( ! anyone out there with a soloution ? PLEASE !
THNX:mad: