iPod touch stuck on HOLD! Need help!

Sutton93

New Member
Jan 18, 2008
2
0
0
#1
Hello, thanks for taking a look at my question.
I have a problem. My iPod touch is stuck on Hold. Yes, I have jailbroken it. I went into the installer app to uninstall a few programs and after I did I hit the home button. Then it restarted and went to the "slide to unlock" screen. The problem is that its stuck there. Its not exactly frozen because the time changes and the little loading thing is in the middle. About every 10-15 seconds I have about 1-2 seconds that I can actually move the "Slide to unlock" thing. But every time I do that then its just goes black and has the loading thing in the middle. Ive tried to plug it into the computer to restore it but the computer cant find it, and ive tried to restart it by holding the hold/home buttons at the same time and it restarts fine but then when it starts back up it just goes back to the same screen. Please help me! I cant send it into Apple because they wont fix it! I just want to restore it so I can download the latest version and be done with all this crap. Thanks in advanced!