iPod won't connect to my WiFi?

  1. icykum

    icykum New Member

    Joined:
    Dec 22, 2011
    Likes Received:
    0
    Hi, I need some help with my iPodTouch (the newest one). I just bought the iPod and I connected to my wireless network and it worked fine for about three days. Then I went out and turned off the network to connect to another network. Now when I come toreconnect with my home wi-fi it loads but does not connect. My sister's iPad and 2 computers connect to the network with ease. I have restored my iPod and it still did not work. What should I do to fix my problem?
     
    #1
  2. applejailescape

    applejailescape Zealot Gold

    Joined:
    Oct 5, 2010
    Likes Received:
    20
    Have you tried to reset the network settings ?
     
    #2
  3. Avatar

    Sponsored Advertisement

  4. Jmbaker429

    Jmbaker429 Evangelist Gold

    Joined:
    Jun 28, 2010
    Likes Received:
    154
    If you have already restored and set up as new then it might be on your router side instead of the iPod. Try changing settings on the router or if possible opens the connection with no security and see if it will connect. Sometimes the security plays a big part in it not connecting. Also make sure you have plenty of connections available on your router.
     
    #3
  5. nanatrisha45

    nanatrisha45 New Member

    Joined:
    Dec 28, 2011
    Likes Received:
    0
    Go to settings/wifi/ go in to the one you can't connect to and "forget this network". Now click on it again and when it asks for password...type in the big long number which is key found on your router or modem. It should work now. we had the same problem.
     
    #4
  6. Jayleeann

    Jayleeann New Member

    Joined:
    Jan 15, 2012
    Likes Received:
    0
    I'm having a similar issue. Bought a new ipod touch today that will not join my wi-fi at home. My husbands touch works fine as does my ipad. Ive tried the restore and also "forget this network". It does connect to my portable MiFi fine but not the home wi-fi. Still reading forums, but if anyone has any suggestions I'd appreciate it.
     
    #5
  7. Lunfai

    Lunfai Member Bronze

    Joined:
    Sep 16, 2010
    Likes Received:
    2
    Try resetting the router sometimes my router doesn't assign an address to my iPhone and I have to reset the router to fix it, it connects but no data gets sent between, give it a try and post back ^^
     
    #6
  8. Jayleeann

    Jayleeann New Member

    Joined:
    Jan 15, 2012
    Likes Received:
    0
    Tried both a reset and a power off and back on twice to no avail. Thanks for the suggestion though.
     
    #7
  9. Shay

    Shay New Member

    Joined:
    Aug 6, 2012
    Likes Received:
    0
    You can try and forget the network, and if that doesn't work. Look if your "ask to join networks" is on. Because that helps. I always have the problem. My Mac doesn't have it but my iPod does.
     
    #8

Share This Page