Is it just me or the phone? Contact.app is slow...

todesto

New Member
Bronze
Sep 30, 2007
59
0
0
#1
Hi, ver.1 user here. After upgrading to 2.0, I notice there is a lag after switching to contact screen. I almost have to wait 3-4 seconds to load to start to scroll down or up. Also, when I also have to wait in search for the keyboard to load. :oops:

Is this normal behavior?

If so, Apple, need 2.1 with improved speed! ;)
 

Revin9k

New Member
Bronze
Jun 24, 2007
33
0
0
#2
Hi, ver.1 user here. After upgrading to 2.0, I notice there is a lag after switching to contact screen. I almost have to wait 3-4 seconds to load to start to scroll down or up. Also, when I also have to wait in search for the keyboard to load. :oops:

Is this normal behavior?

If so, Apple, need 2.1 with improved speed! ;)
happens to me too. just the first time a press it though. once its loaded and i go back to it, its quick.
 

daziphone

Member
Bronze
Jul 4, 2007
62
0
6
Columbus OH
#4
My iPhone (original not 3G) has an overall lag to it since 2.0 upgrade. I notice it being slower in general. It is irritating, hope Apple does a 2.0.1 fix soon.
 

guest4

Member
Bronze
Mar 27, 2008
182
0
16
#5
I can't stand the lag when texting. It's the most annoying thing ever.
 

cybergreg

New Member
Jul 21, 2007
26
0
0
#6
Turn off push to your Contacts (re-sync) and it's almost back to pre-2.0, at least it is for mine.
 

techfront

New Member
Jul 16, 2008
1
0
0
#7
Original iPhone on 2.0 feels like a Beta at best

There's a saying in the technology world regarding a new release: Whatever you do, don't go backwards. Well, Apple, you forgot this simple adage. And going backwards does not refer to new features. It refers to the user experience. My upgraded iPhone is a major step backwards. Here are the most notable downgrades:

-- The camera takes 5-8 seconds to open up and the shutter now takes 2-5 seconds to capture an image. (No longer a camera, more of a bad toy) It used to take 1 second and 1 second respectively (An acceptable convenient camera).

-- Right after the upgrade, my POP email account completely stopped syncing. I had to activate MobileMe on the iPhone (thankfully I was a legacy .mac account holder) and then delete and rebuild my original mail account (twice) before it would start syncing again. This type of stuff really reminds me of the kind of things the guy you make fun of in your ads does.

-- The contacts app hesitates 2-4 seconds before opening up and then another 1-2 seconds between letters when I'm looking for someone.

-- The general delay between apps is anywhere from 1-3 seconds.

All-in-all, I upgraded from 1.1.4 to 2.0 to get the Apps store and some new features. But what I really got is a much poorer user experience until something can be fixed. I hope the complexity of the integration between all of these apps coupled with the cloud vision of MobileMe hasn't rendered the older device to its sorry state for good. If I have to, I will upgrade to the 3G version, but I would do so begrudgingly. I really liked the original iPhone. And, I will likely re-install the earlier version of software. Oh, and a nice upgrade would've been MMS which has been around for about a decade now...

The door is now officially open for G**gle. This could get interesting...