Issue with WeatherIcon

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

medenblik

Contributor
Silver
Mar 25, 2010
834
44
28
#1
I have always used this in past JB's IP3, IP3GS, iPhone 4 and now trying to use it again with IP4S.

you get it off Cydia and you enable it in settings...........it allows you to put the weather on the STATUS BAR (temperature number)

it worked on my brothers IP4S and also my friends 4S but it will not show up on mine.....

I have un-installed it and did hard reset and then waited and installed and did hard reset and still it doesn't show up on my status bar......

has anyone else use weather Icon?

just trying to see if anyone else has issues too..........

thanks
 

medenblik

Contributor
Silver
Mar 25, 2010
834
44
28
#4
Yes and I turned them all on and hard reset. Still nothing.

I try just enabling it and just the weather temp with no luck. Also on the app I tried showing badge and image too. Neither work.

Do they both work on yours?

I am at a loss as to why it isn't working.
 

iphonewarrior

Moderator
Moderator
Apr 11, 2008
13,847
700
113
#5
Yes and I turned them all on and hard reset. Still nothing.

I try just enabling it and just the weather temp with no luck. Also on the app I tried showing badge and image too. Neither work.

Do they both work on yours?

I am at a loss as to why it isn't working.
They work on my iPhone 4 but I couldn't tell you if it's compatible with the iPhone 4S. Launch Cydia search for WeatherIcon and take a look at the changelog. The iPhone 4s may not be supported yet.
 

medenblik

Contributor
Silver
Mar 25, 2010
834
44
28
#9
yeah it worked great on my iPhone 4 too..................and I resprung and hard reset soo many times and still nothing

i have deleted and re-installed.............

gotta be something that I cannot think of...........really annoying
 

IceCold357

Contributor
Silver
May 1, 2009
571
39
28
#10
yeah it worked great on my iPhone 4 too..................and I resprung and hard reset soo many times and still nothing

i have deleted and re-installed.............

gotta be something that I cannot think of...........really annoying
Are you using a theme from Winterboard on there? I had an issue when I first installed it and had to go into my theme setting to take off a weather toggle. After I changed that it popped up. I am using CarbonX Pro.


Sent from my iPhone using iCafe app
 

Attachments

medenblik

Contributor
Silver
Mar 25, 2010
834
44
28
#11
i have taken everything off in winterboard and still doesn't show up..........

I am at a loss................so stinking weird issue
 

theorioles33

Evangelist
Silver
Jul 21, 2007
925
136
63
USA
#12
Well I was hoping to help you debug this. I installed it on my 4S and it just works. Live weather icon and status bar temp and icon. Sorry!
 

medenblik

Contributor
Silver
Mar 25, 2010
834
44
28
#13
well i might have something.........my weather icon....the normal one..

well on mine it is blank blue, doesn't show weather until I click on it........

see pic...... you think that may be the issue? and if so how do I get it to show the weather or the SUN like normal? yes I have it selected in weather icon in settings

 

theorioles33

Evangelist
Silver
Jul 21, 2007
925
136
63
USA
#14
well i might have something.........my weather icon....the normal one..

well on mine it is blank blue, doesn't show weather until I click on it........

see pic...... you think that may be the issue? and if so how do I get it to show the weather or the SUN like normal? yes I have it selected in weather icon in settings

Could it be conflicting with a another theme?
 

medenblik

Contributor
Silver
Mar 25, 2010
834
44
28
#15
not using a theme.....it is just a background wallpaper and 4G icon instead of 3G.......and using shrink..............but it wasn't working before i d/l shrink and the 4G.......

wonder if I can someone to send me the weather.app and try installing it on my phone with SSH...........

think that might work?
 

theorioles33

Evangelist
Silver
Jul 21, 2007
925
136
63
USA
#17
not using a theme.....it is just a background wallpaper and 4G icon instead of 3G.......and using shrink..............but it wasn't working before i d/l shrink and the 4G.......

wonder if I can someone to send me the weather.app and try installing it on my phone with SSH...........

think that might work?
Hmmm. I don't know. This is an odd one.
 

theorioles33

Evangelist
Silver
Jul 21, 2007
925
136
63
USA
#18
I remember in the "old days" you used to need Katra Weather to get it to work sometimes. You can try that for the heck of it.

Katra weather based icon in Cydia.
 

IceCold357

Contributor
Silver
May 1, 2009
571
39
28
#19
Could it be conflicting with a another theme?
I'm no expert but I think it may be confused or conflicted with all the weather apps that you have. It may be trying to pull a status from all of them or something to that effect.


Sent from my iPhone using iCafe app
 

medenblik

Contributor
Silver
Mar 25, 2010
834
44
28
#20
ok...............so my buddy sent me his web.app and I install it with winscp and now my weather shows back up on my homescreen as seen in the pic.


but then I go and install weathericon from cydia and ofcourse it doesn't work and my weather icon goes back to just a blank blue icon..........as sen in next pic...




so it doesn't seem to like my IP4S............i know it must be supported as it works on my brothers IP4S and you guys here say it works for you..

just weird...........