iTunes no longer recognises iPhone - tried everything.

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

ColdFire

New Member
Nov 20, 2007
13
0
0
#1
Hi all,

I realse that this problem probably gets asked a lot, but i am at the end of my teather with iTunes + iPhone.

When i got my o2 iPhone i connected and went through the activation process without any issues at all. Since then i have been able to connect my iPhone a couple of times but whilst connected it would constantly disconnect and then reconnect straight away again.

This started getting more and more common (especially after 1.1.2 jailbreak) until the point where iTunes started erroring "iTunes could not connect to the iPhone because an unknown error occurred".

Now it simply does not recognize i have the phone connected, infact the iPhone battery icon doesn't switch to the charging icon (it does when plugged into a wall socket).

I have unistalled iTunes and all associated Apple'y things in control panel but when i reinstall iTunes it remembers all my settings! I have also reset everything on the iPhone and still no joy.

Basically how the hell do i completely remove iTunes and iPhone from XP so that when i reinstall iTunes it doesn't remember anything? Then hopefully windows xp will pop up the balloon saying new usb device recognized etc.

Also if i can actually get rid of iTunes entirely will it effect my MP3's? They were only imported into iTunes the other week, i usually use winamp.

Thanks for your time.

P.s i tried iPhone on my usb1 laptop also but it wouldn't install. It kept saying usb device not installed correctly, could it be an issue with the iPhone its self as opposed to iTunes as i initially suspected?
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
30
Atlanta, Georgia
#2
It is very possible that the little metal receivers on the bottom of the phone (sorry for the lack of a better term) may be bent thus not allowing iTunes to recognize the iPhone. Another issue might be with the USB cable you are using. If possible, try using a different iPod cord to connect to the computer. To completely remove iTunes, go to your control panel and uninstall the program from there and it should remove most if not all remnants of it.
 

ColdFire

New Member
Nov 20, 2007
13
0
0
#3
Hey, Thanks for the reply.

Yeah i though that the pins might be bent or something but looking at my friends touch they don't seem any different, also as i have said the phone charges fine.

I have tried unistalling iTunes from add/remove programmes but when i reinstall it remembers where all my music is (not in default folder) and remembers that i have connected iPhone.

I need to get rid of iTunes completely so that when i reconnect my iPhone it thinks that its the first time it is being connected and loads all the drivers etc.

Gonna try the iPhone on my friends macbook tomorrow, if it doesn't work on there then it must be the phone itself.
 

ColdFire

New Member
Nov 20, 2007
13
0
0
#5
^ Yeah i have tried reinstalling iTunes and i still get the same problem. On top of that there doesn't seem anyway to COMPLETELY remove iTunes to force windows to reinstall the iPhone drivers when i reconnect it.

iTunes and the PC remember my iPhone and settings even after an uninstall > reinstall.
 

ColdFire

New Member
Nov 20, 2007
13
0
0
#6
Just a little update on this,

I tried today to connect my iPhone to my work pc and it connected fine and had none of the issues i am getting with my home pc.

Sooooo, either the USB on my home pc is knackered or its iTunes thats doing it. I don't think the USB has a problem because my old Nokia used to work a treat.

So its kinda back to my original question, how do i completely remove iTunes from my system so that when i reinstall it windows has to install the drivers for the iPhone. I guess i need to clean the registry out or something for this?
 

smitty24

New Member
Bronze
Nov 13, 2007
81
0
0
Lakeland, FL
#7
Just a little update on this,

I tried today to connect my iPhone to my work pc and it connected fine and had none of the issues i am getting with my home pc.

Sooooo, either the USB on my home pc is knackered or its iTunes thats doing it. I don't think the USB has a problem because my old Nokia used to work a treat.

So its kinda back to my original question, how do i completely remove iTunes from my system so that when i reinstall it windows has to install the drivers for the iPhone. I guess i need to clean the registry out or something for this?
cleaning the registry may be a good idea....you may want to check your AutoPlay settings. You may have selected 'Do Nothing' when iPhone is connected. Also, try Add/Remove Hardware when its plugged in to your computer...just a thought
 

ColdFire

New Member
Nov 20, 2007
13
0
0
#8
Hi Smitty, thx for the suggestions i will try them when i get home.

Do you know how to change the autoplay settings if it doesn't pop up? I also have this really annoying issue where by Windows XP camera wizard pops up asking me if i wanna pull the photos off the iPhone.
 

smitty24

New Member
Bronze
Nov 13, 2007
81
0
0
Lakeland, FL
#9
Hi Smitty, thx for the suggestions i will try them when i get home.

Do you know how to change the autoplay settings if it doesn't pop up? I also have this really annoying issue where by Windows XP camera wizard pops up asking me if i wanna pull the photos off the iPhone.
I know in Vista, there is a way to change specific device settings with Autoplay. for XP, you have to plug it in then right click on it in 'My Computer' and go to "AutoPlay" and change there. Check your device manager to see if the iPhone is recognized or not.

As for the camera wizard, if you don't want it to come up, choose 'Do nothing' on the autoplay screen and that shouldnt come up any more.

One more thought, if the usb cable is good, and you know for a fact it is, plug it into a different usb port on your computer and see if it recognizes then. may be a bad USB port altogether...
 

ColdFire

New Member
Nov 20, 2007
13
0
0
#10
Hi Smitty,

Thanks for your continued responses.

The pc doesn't seem to recognize the iPhone at all now. It isn't showing up in device manager and the camera and scanner wizard auto runs and then says that it cant find the camera.

I have tried using a different port but still no joy. I know the cable and the phone are fine from using it on my work pc.

I think that the usb ports are fine because i used to use my Nokia N70 on the two at the front without ever having an issue.

I think my only chance is to uninstall iTunes and everything Apple related and then go through the registry and remove anything Apple related also.

I'm a bit scared (lol) of going throigh the registry though as i don't wanna break anything.
 

smitty24

New Member
Bronze
Nov 13, 2007
81
0
0
Lakeland, FL
#11
wow, i cant believe that none of those worked. I guess the pins could very likely be bent (on the phone) then. device manager should have recognized at least an unknown device...

only other thing i can think of is to try a usb port on the back or something else in the front. you need to confirm that all USB devices are ok...

also may want to check the services and make sure all appropriate ones are running.
see here: http://docs.info.apple.com/article.html?artnum=305716

if all else fails, reboot?

hopefully we can figure out what exactly is going on...good luck!
 

ColdFire

New Member
Nov 20, 2007
13
0
0
#12
Well i did think the pins might be bent too but like i say it works perfectly on my pc at work. I am convinced that it is some software issue with windows and the iPhone.

The service always starts fine so that cant be the issue and i have tried to connect it to multiple ports in the front and the back and still no joy.

I am going to go ahead and completely remove any trace of iTunes from the registry. Also iTunes must save my phone backup somewhere because when i reinstall iTunes it has the option for me to restore, do you know where it might be saving this backup to?
 

smitty24

New Member
Bronze
Nov 13, 2007
81
0
0
Lakeland, FL
#13
Well i did think the pins might be bent too but like i say it works perfectly on my pc at work. I am convinced that it is some software issue with windows and the iPhone.

The service always starts fine so that cant be the issue and i have tried to connect it to multiple ports in the front and the back and still no joy.

I am going to go ahead and completely remove any trace of iTunes from the registry. Also iTunes must save my phone backup somewhere because when i reinstall iTunes it has the option for me to restore, do you know where it might be saving this backup to?
that is weird...hopefully it will work on the reinstall...

looks like the location is in the advanced setting of the preferences in iTunes.
 
Last edited by a moderator:

ColdFire

New Member
Nov 20, 2007
13
0
0
#14
Ok a little update, i have managed to get iTunes uninstalled completely so that wheni did reinstall the computer went through the add new hardware wizard.

So now i have managed to connect and sync ok, the only downside is that i cannot stop the camera and scanner wizard from starting up and because i have a password on my outlook file it asks me to put it in about 3 times before it will sync.

Still at least i can get music on there now. Thanks for your help Smitty.
 

smitty24

New Member
Bronze
Nov 13, 2007
81
0
0
Lakeland, FL
#15
Youre welcome. glad you got it partially working, at least the music part. AS for the password problem, go into your outlook email account setting and tell it to save the password on the account so you don't have to reenter it each time.