jail break problems

Sep 30, 2011
8
0
1
#1
PLEASE HELP. I have jail broken my 3gs using red snow, with a tethered boot because I have 4.3.5 software version. It will not sync with iTunes or reset back to factory, the worst bit is I do not get signal any more, it says no service all the time, please help!
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#2
Moved to iPhone Jailbreak.

Are you using AT&T?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#5
It's a carrier in the United States. Are you using an official carrier (the one that the phone is tied to)? Have you ever unlocked the phone?

You could try disabling 3G and resetting your network settings.
 

Flattsteve

New Member
Sep 30, 2011
8
0
1
#6
Hi, I never unlocked it and I am still using Orange which is the original carrier, I tried disabling 3g and resetting but still no change.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#7
What happens when you try to restore to factory settings?
 

Flattsteve

New Member
Sep 30, 2011
8
0
1
#8
it fails and gives an error message 3194, it now communicates with i tunes, uninstalled and reinstalled.
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#9
You need to edit your hosts file so it points to Apple if you want to restore to 4.3.5 or Cydia if you want to restore to 4.3.3. You'll need a 4.3.3 SHSH if that's what you're trying to restore to.
 

Flattsteve

New Member
Sep 30, 2011
8
0
1
#10
any idea were to find them or how to do it? I would prefer to remove the jail brake
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#11
Edit your hosts file and put a pound sign in front of Saurik's server address and then shift+restore.
 

Flattsteve

New Member
Sep 30, 2011
8
0
1
#12
Hi where abouts is the host file and how do I edit it, I was looking in C:\Windows\System32\drivers\etc but I am struggling to find it
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,453
5,578
113
Utah
#13
Start > Notepad > Right click > Run as Administrator
C:\windows\system32\drivers\etc
 

Flattsteve

New Member
Sep 30, 2011
8
0
1
#14
Hi,

FIXED IT, in the end I did a forced restore, put the phone in dfu (I think) by holding the power button for 3 secs then join that with the home for another 10 then release the power button still holding home for another 15, connect to iTunes and restore. Then woo hoo it works.

thanks for all youre help anyway.

Cheers
Steve