Just swapped iPhone with Android... iPhone recipients still sending via iMessage

Discussion in 'iPhone 5' started by altjx, Dec 26, 2013.

  1. altjx

    altjx Member
    Bronze

    Joined:
    Oct 21, 2009
    Likes Received:
    10
    I used to have an iPhone and just swapped it with a Samsung Galaxy Note 3. However, some of my recipients who are still using iPhones are trying to communicate with me, but the messages are coming via iMessage (i can tell via my mac). Therefeore, I'm not getting my messages on my Android phone.

    This is very annoying.
     
  2. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    958
    When you say, "swapped", do you mean traded in for a new Note 3 at a store, or swapped with person for a used one?


    Sent using iCafe app
     
  3. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,467
    Did you restore it or turn iMessages off before you traded it?

    Go to here and unregister the iPhone.
     
  4. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    958
    Would that affect his receiving messages on his Note 3 from others with iPhones?


    Sent using iCafe app
     
  5. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,467
    Yes. What the OP described is a very common problem.
     
  6. altjx

    altjx Member
    Bronze

    Joined:
    Oct 21, 2009
    Likes Received:
    10
    Hey guys,

    Thanks for your link Europa. I actually went there shortly after posting the thread, but I can still send messages via iMessages on my Macbook Pro - not sure if this is essentially "re-activating" it or not.

    Also, by swapped, I mean I traded it for the Note 3 at Verizon. However, I made sure to "Erase All Content and Settings" before I gave it to them. I didn't turn iMessages before trading it.

    EDIT: My iPhone friends are still saying that my number is still showing up as an iMessage.
     
    #6 altjx, Dec 26, 2013
    Last edited: Dec 26, 2013
  7. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    958
    This worked for someone with the exact same problem. Here's what they said.

    Ok after many frustrating hours of trying to fix this messaging issue and trying everything that has been recommended I think I found a solution. Go to Appleid.apple.com sign in and go to PHONE NUMBERS and DELETE the phone number that has been updated to the Samsung Galaxy Note 3 "If you have more then one iPhone on that account" also at the same time Change your password. After I did this I received about 10 messages that were stuck in "Limbo" As of right now all my messages are going out and coming in just as they should. I hope this helps ! Good Luck



    Sent using iCafe app
     
  8. altjx

    altjx Member
    Bronze

    Joined:
    Oct 21, 2009
    Likes Received:
    10
    Unfortunately, I can't delete my phone number from the "Phone Numbers" section.

    [​IMG]

    However, I'm going to reset my password now though and give it a shot.

    EDIT: Jesus, I can't even reset my password now because I don't remember the security questions. The "forgot your security answers" email address is invalid and no longer in use.

    Guess I'll have to call Apple about this issue. I'll update you guys if they give me a suggestion other than yours.
     
  9. altjx

    altjx Member
    Bronze

    Joined:
    Oct 21, 2009
    Likes Received:
    10
    UPDATE 6:48 PM: Just got off the phone with Apple and they mentioned that I'd have to give Samsung a call about this. I'll update once talking with Samsung.
     
    #9 altjx, Dec 26, 2013
    Last edited: Dec 26, 2013
  10. Europa

    Europa Moderator
    Senior Moderator

    Joined:
    Dec 12, 2008
    Likes Received:
    5,467
    I don't see how Samsung could help with this. It's an Apple service that's difficult to kill and switch over to the carrier.

    Here are a few more things to try:
    1. Change your Apple ID password.
    2. Toggle airplane mode off/on.
    3. Reset your network settings on the Android.
    4. Ask your friends with an iPhone to reboot.

    You should still be able to use iMessages on an iPad and your MacBook. They are setup with an email account rather than the phone number.
     

Share This Page