LCD Replacement gone wrong

Aug 3, 2011
29
0
1
Akron, Ohio
#1
Okay so I figured with my electronic knowledge and the relative ease with all the YouTube tuts I would just replace my Apple iPhone 3g LCD screen. So I did and everything went solid. I turned it on without sealing the case all the way and it worked. However the 1st connector came undone and I put it back on with the phone powered up. Now the new LCD wont even turn on. Is it possible that I burned the new LCD out? I put in my old LCD and it atleast came up all White so I knew it was getting power atleast. Also does the 3rd connector have to be pushed all the way in so that the line above the copper is flush? I cant get it to go all the way in but when I had it working before the screen messed up I don't think it was sitting flush.

Thanks
Mike
 
Aug 3, 2011
29
0
1
Akron, Ohio
#2
Additional Info:

When I plug the usb in my iPhone still makes the noise to let me know its connected.
But when I push the power button I don't hear the locking noise.
I also tried rebooting it and had no luck there.
Also iTunes still recognizes my phone and syncs fine.
 

Clay125

Member
Bronze
Mar 16, 2011
41
0
6
#3
You said you rebooted it but did you do the hard reboot where you hold down both buttons for 20 seconds?
 
Aug 3, 2011
29
0
1
Akron, Ohio
#4
If you mean hold down the power for 2 seconds then both the power and home and then finally home, then yes. I also pulled the 4th connector because thats supposed to kill the power to right? I even pulled the battery and put it back in. Im stumped. The funny thing is that both my new and my old screen are black. I was still able to use my old screen too. I have no idea if I blew both LCDs or im doing something wrong.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
48
ATL
#7
Okay so I figured with my electronic knowledge and the relative ease with all the YouTube tuts I would just replace my Apple iPhone 3g LCD screen. So I did and everything went solid. I turned it on without sealing the case all the way and it worked. However the 1st connector came undone and I put it back on with the phone powered up. Now the new LCD wont even turn on. Is it possible that I burned the new LCD out? I put in my old LCD and it atleast came up all White so I knew it was getting power atleast. Also does the 3rd connector have to be pushed all the way in so that the line above the copper is flush? I cant get it to go all the way in but when I had it working before the screen messed up I don't think it was sitting flush.

Thanks
Mike
Yes, you fried the video screen. Lucky if you didn't fry anything else. Most electronic components will fry if not properly Connected before hand. The reason is that there are multiple spots where current is running, and also the ground. When connecting to a port that is powered, current jumps to the path of least resistance, and generally that's not where it is supposed to go.
Hopefully just the screen is damaged and nothing else.
 
Aug 3, 2011
29
0
1
Akron, Ohio
#8
@hawk thanks much appreciated. I couldnt see anything but everything else appeared to be fully functional from what I was hearing. Again I wont know for certain until I get the new screen.
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
48
ATL
#10
You just did. :)
It will remain open in case someone else has the same problem and finds this thread.