Mail being stupid?

Dustu2

Member
Bronze
Jul 16, 2008
478
1
18
Houston, TX
#1
My phone refuses to connect to my Gmail account. Upon opening the app, I receive this pop-up;



I have tried erasing the password and re-entering it, and I've tried restarting the phone. I KNOW that the password I've entered is correct, capitalization and all. Any ideas?
 

Europa

Moderator
Senior Moderator
Dec 12, 2008
28,365
5,507
113
Utah
#2
Delete the Gmail account from the phone and then reenter it. If that doesn't work, reset network settings.
 

Eninety2

Member
Silver
Jul 22, 2008
568
9
18
#4
out of curiosity did you have it set up as gmail or other?
 

stevetim

New Member
Silver
Jul 20, 2007
606
0
0
#6
I set up Gmail in my Mac's email account. Then under Info/mail accounts in iTunes, I let it sync to the iPhone. Takes a step out of the password issue.
 

ZipZap

Member
Silver
Dec 15, 2007
529
1
18
#7
I solved this problem by simply re-entering the SMTP password. No need to delete the account.
 

Dustu2

Member
Bronze
Jul 16, 2008
478
1
18
Houston, TX
#8
I set up Gmail in my Mac's email account. Then under Info/mail accounts in iTunes, I let it sync to the iPhone. Takes a step out of the password issue.
that's a great idea! Just as soon as I save up enough for a Mac. =\

I solved this problem by simply re-entering the SMTP password. No need to delete the account.
I tried. I re-entered every password in the mail settings.
 

iphonediva

Member
Bronze
Feb 27, 2009
33
0
6
Anaheim
#9
gMAIL

My gmail account did that to me yesterday:dft008:surprised...i deleted the account and tried to reenter the info...no go...then i googled the error and i found that entering a new, stronger password was the issue...works fine now:eek:k:eek:k
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#10
I always set it up as Other so that I can use the imap feature on Gmail.
You shouldn't have to do that anymore. I just used the Gmail setup icon and all was good, IMAP wise, when setting up my 3GS. It even used port 587 for SMTP.

Actually it was not all good: since I did a restore when upgrading to the 3GS my mail accounts were already loaded. The first time I used Mail it asked for my Gmail password, which I entered. Mail worked, but then sending would not (same ol' SMTP server password error).

However, I could not change the SMTP password within settings, so deleted the account and set it up again (using just the Gmail icon from within Mail setup). All worked well. Ditto for another Gmail account I setup--all started out as IMAP.

BTW: I still cannot change the SMTP password within Mail settings. It's grayed out. I can access the IMAP server password, however,



--
Mike
 

Dustu2

Member
Bronze
Jul 16, 2008
478
1
18
Houston, TX
#11
You shouldn't have to do that anymore. I just used the Gmail setup icon and all was good, IMAP wise, when setting up my 3GS. It even used port 587 for SMTP.
Yeah, I would imagine that Google/Apple had changed it in an update. But I remembered having to do it through the "other" option when I first got my 3G, and I was far too lazy to actually get on the Gmail website and check.
 

Tinman

Evangelist
Gold
Jul 16, 2007
4,334
183
63
Aridzona
#12
Yeah, I would imagine that Google/Apple had changed it in an update. But I remembered having to do it through the "other" option when I first got my 3G, and I was far too lazy to actually get on the Gmail website and check.
I used to use "other" but tried the Gmail icon because I was too lazy to lookup the alternate SMTP port. ;)

Things have changed in the last two years. I remember, a few months into the G1's release, waiting for like forever for my Gmail account to even have IMAP turned on, and then having to manually set it up on the iPhone, of course.




--
Mike