Mail fails to send

mickey35

New Member
Bronze
Sep 5, 2007
54
0
0
#1
I use Mail for e-mail.
Now and then, and right now, when I send am e-mail I get the window that says "msg not sent, sender address invalid"
What the heck causes this? Needless to say I've never changed my e-mail address. And I continue to receive mail at my address.
This had occurred before. Some times the msge(s) go out days later, but, most often never.
 

Watcher

Zealot
Gold
Mar 29, 2009
1,785
30
48
Phoenix, AZ
#2
Many questions...

What OS are you running on the iPhone? 3.0 Beta 5?
What email service do you have? Gmail, Yahoo, Hotmail?
Did you try a reboot?
Do you have your mail set to Fetch New Data?
 

mickey35

New Member
Bronze
Sep 5, 2007
54
0
0
#3
Many questions...

What OS are you running on the iPhone? 3.0 Beta 5?
What email service do you have? Gmail, Yahoo, Hotmail?
Did you try a reboot?
Do you have your mail set to Fetch New Data?
OS is 2.2.1 (5H11)
What mail? Not certain what you mean here. I use Apple Mail, the same as I do on my Macs. My service if via Comcast Cable. But I do not use Yahoo, of whatever they provide for mail.
I did reboot once the first time it occurred. I did not fix the problem that time.
No, Fetch New Data is OFF.
Thanks
 

iphun

Zealot
Gold
Mar 16, 2009
1,967
0
36
PA
#4
OS is 2.2.1 (5H11)
What mail? Not certain what you mean here. I use Apple Mail, the same as I do on my Macs. My service if via Comcast Cable. But I do not use Yahoo, of whatever they provide for mail.
I did reboot once the first time it occurred. I did not fix the problem that time.
No, Fetch New Data is OFF.
Thanks
What are all your settings for this account? This is under settings> mail, contacts, calendars> Comcast email account. I have my comcast email set up and it works so maybe some of your settings are wrong.
 

mickey35

New Member
Bronze
Sep 5, 2007
54
0
0
#5
What are all your settings for this account? This is under settings> mail, contacts, calendars> Comcast email account. I have my comcast email set up and it works so maybe some of your settings are wrong.
Here is what is on my iPhone.
POP acct info:
Name: G. Michael Paine
Address: mipaine@comcast.net
Description: POP Account
Host Name: mail.comcast.net
User name: mipaine
Password: xxxx

Is this the info you needed?
I hope so. I still cannot send an e-mail from the phone.
 

iphun

Zealot
Gold
Mar 16, 2009
1,967
0
36
PA
#6
Here is what is on my iPhone.
POP acct info:
Name: Your name
Address: xxxx@comcast.net
Description: POP Account
Host Name: mail.comcast.net
User name: xxxx
Password: xxxx

Is this the info you needed?
I hope so. I still cannot send an e-mail from the phone.
I wouldn't have all your info there I removed it from the reply quotes just in case you edit it out. Yeah that all looks like what I have. There's something I found for you to try, open the outgoing mail server that should read smtp.comcast.net and turn on the AT&T SMTP Server, I also have two smtp.comcast.net servers for my email address and I have both turned on.
 

mickey35

New Member
Bronze
Sep 5, 2007
54
0
0
#7
I wouldn't have all your info there I removed it from the reply quotes just in case you edit it out. Yeah that all looks like what I have. There's something I found for you to try, open the outgoing mail server that should read smtp.comcast.net and turn on the AT&T SMTP Server, I also have two smtp.comcast.net servers for my email address and I have both turned on.
Thanks. It is a 100 degrees right now, I will play with my phone later this evening.
if I make the change suggested I assume I can re-enter the originals?
Any idea why the spasmodic play here?
 

iphun

Zealot
Gold
Mar 16, 2009
1,967
0
36
PA
#8
Thanks. It is a 100 degrees right now, I will play with my phone later this evening.
if I make the change suggested I assume I can re-enter the originals?
Any idea why the spasmodic play here?
You are just turning on back up servers in case it fails on the main one. It says that at the bottom of the screen with all the servers.
Here is the link where I found this just go to the first resolution "In Settings, turn on other SMTP servers" http://support.apple.com/kb/TS1426

I have no idea, do you?
 

2white2fight

New Member
Bronze
Mar 31, 2009
196
0
0
925 the bay
#9
yes and when i go to my mail it goes into my outbox and then i don't know how to send it!
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#10
Just reload (tap the arrow that is a circle in the bottom corner) the account, it will attempt to send it again.
 

mickey35

New Member
Bronze
Sep 5, 2007
54
0
0
#11
Just reload (tap the arrow that is a circle in the bottom corner) the account, it will attempt to send it again.
That has been tried many times, no connection and no msg sent.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#12
Sorry, my answer was for the other user. I think you need to set your smtp server to something other than comcast, I use the AT&T smtp server for my ISP email. My ISP will not allow a wireless device to access the smtp server.
 

mickey35

New Member
Bronze
Sep 5, 2007
54
0
0
#13
Well, the odd thing happened again.
After almost a week of not being able to send e-mail, suddenly my old msgs got sent as of this morning I can write and send an e-mail instantly.
Go figure! This is the same scenario I've had before. Nothing going out for days and suddenly all msgs in Draft go out on their own.
I give up.

Thanks