Mail just spins and spins - doesn't actually check

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

philhh

New Member
Bronze
Jul 30, 2007
38
0
0
#1
So my mail application doesn't actually seem to get my mail...even when it says it is doing so. I have 2 Yahoo accounts, a .Mac account, and 2 other accounts.

This started happening after the first or second update I performed...I think.

I've noticed that while the Mail app says it is checking, the only time it actually retrieves mail is when I see a spinning icon just to the right of the Edge or WiFi symbol up top. More often than not, I don't see that symbol except for immediately after I restart my phone.

Do I need to wipe and re-load? And if so is there anything that iTunes doesn't just automatically restore? My iPhone is stock.

Thanks in advance!

-Phil
 

meiphones_brill

New Member
Silver
Nov 16, 2007
797
0
0
#2
So my mail application doesn't actually seem to get my mail...even when it says it is doing so. I have 2 Yahoo accounts, a .Mac account, and 2 other accounts.

This started happening after the first or second update I performed...I think.

I've noticed that while the Mail app says it is checking, the only time it actually retrieves mail is when I see a spinning icon just to the right of the Edge or WiFi symbol up top. More often than not, I don't see that symbol except for immediately after I restart my phone.

Do I need to wipe and re-load? And if so is there anything that iTunes doesn't just automatically restore? My iPhone is stock.

Thanks in advance!

-Phil
I've had this once - I did a 'Reset all settings' and recreated the mail accounts - that did the trick.
 

KNK

New Member
Jul 22, 2007
2,391
1
0
Stevenson Ranch
#3
So my mail application doesn't actually seem to get my mail...even when it says it is doing so. I have 2 Yahoo accounts, a .Mac account, and 2 other accounts.

This started happening after the first or second update I performed...I think.

I've noticed that while the Mail app says it is checking, the only time it actually retrieves mail is when I see a spinning icon just to the right of the Edge or WiFi symbol up top. More often than not, I don't see that symbol except for immediately after I restart my phone.

Do I need to wipe and re-load? And if so is there anything that iTunes doesn't just automatically restore? My iPhone is stock.

Thanks in advance!

-Phil

If you did a restore you have to go back into your settings for the mail and re-input you mail settings, as well as wifi setting phrase.