Mail not syncing with iPhone

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#1
I have 118 messages in my inbox on my MBP and 12 messages on my phone. How can I sync between the two devices? I've set up iCloud on both devices. In the mail app, all my accounts are using IMAP. I'm not sure what else it might be so maybe someone can help.
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#2
Still no replies... I'm thinking that the issue is that Outlook does not sync with iCloud. Can anyone confirm this? I can't get my email to sync on my iPhone and MBP. I've considered using a different mail client on Mac. Which one do you use?
 

Lon

Evangelist
Gold
Jun 5, 2010
2,946
132
63
Alaska
#3
Still no replies... I'm thinking that the issue is that Outlook does not sync with iCloud. Can anyone confirm this? I can't get my email to sync on my iPhone and MBP. I've considered using a different mail client on Mac. Which one do you use?
I use the standard mail client on Mac, rather than trying to use Outlook or other 3rd party ones. Go to iCloud.com and log in and see if all your mail is there. That might tell you which device you are having problems with. Is there a setting in iCloud on the Mac in Settings that might redirect it?
 

silvermoon

Evangelist
Gold
Jul 17, 2013
1,624
179
63
Washington
#4
I use the standard mail client on Mac, rather than trying to use Outlook or other 3rd party ones. Go to iCloud.com and log in and see if all your mail is there. That might tell you which device you are having problems with. Is there a setting in iCloud on the Mac in Settings that might redirect it?
OK, I checked on iCloud.com with my Mac and my mail is not showing up there. I found a setting in iCloud on the Mac. I have iCloud Drive and iCloud turned on. It seems when I delete a message in Mail on my iPhone, the change does not take effect on my Mac. That is what I'm trying to figure out.
 

Lon

Evangelist
Gold
Jun 5, 2010
2,946
132
63
Alaska
#5
OK, I checked on iCloud.com with my Mac and my mail is not showing up there. I found a setting in iCloud on the Mac. I have iCloud Drive and iCloud turned on. It seems when I delete a message in Mail on my iPhone, the change does not take effect on my Mac. That is what I'm trying to figure out.
Sounds like there is a communications issue between your MPB and iCloud, not between iCloud and your iPhone. Double check your iCloud Control Panel. Frankly, in mine, I don't have the option of selecting Outlook. I am just going to guess that Outlook on the MBP does not sync with iCloud - this is just a guess now. Maybe someone else is more knowledgable than I am. Is there any reason you are using Outlook rather than the native Mac email?