Mail settings won't save

Welcome to our Community
Wanting to join the rest of our members? Feel free to sign up today.
Sign up

Popdevil

New Member
Bronze
Jul 2, 2007
254
0
0
#1
I changed the settings on the iPhone to delete mail off the server. I change the settings and go back to the home screen and do a few other things and then when I go back it is set to NEVER delete mail off the server again.
 

TrippalHealicks

New Member
Gold
Mar 2, 2007
1,341
0
0
#2
I changed the settings on the iPhone to delete mail off the server. I change the settings and go back to the home screen and do a few other things and then when I go back it is set to NEVER delete mail off the server again.
yeah, mine does that too. It's some sort of bug, i'm assuming... I've changed it back on several times, and eventually it saved it, for some reason...? haha
 

Popdevil

New Member
Bronze
Jul 2, 2007
254
0
0
#3
yeah, mine does that too. It's some sort of bug, i'm assuming... I've changed it back on several times, and eventually it saved it, for some reason...? haha
I thought at first it was because I was syncing my mail accounts via iTunes but I unchecked that and it still does it.
 

rumpelgeist

New Member
Bronze
Jun 20, 2007
165
0
0
#4
I thought at first it was because I was syncing my mail accounts via iTunes but I unchecked that and it still does it.
Mine does the same thing. It is INTENSELY annoying.

I had exchanged my phone due to battery life issues. The first one kept the setting to remove mail from the server just fine, this one doesn't; this one always reverts to "never".

Makes no sense whatsoever.

Ah me!

Rumpelgeist
 
Jul 12, 2007
21
0
0
#5
Suggestion: Delete the mail account from the device and recreate the account on the device itself, rather than via iTunes. Make sure all is working to your requirements and THEN set it up to sync via iTunes. Worked for me, but YMMV.

Lee
 

rumpelgeist

New Member
Bronze
Jun 20, 2007
165
0
0
#6
Suggestion: Delete the mail account from the device and recreate the account on the device itself, rather than via iTunes. Make sure all is working to your requirements and THEN set it up to sync via iTunes. Worked for me, but YMMV.

Lee
Already tried that.

Rumpelgeist
 

Popdevil

New Member
Bronze
Jul 2, 2007
254
0
0
#7
I haven't tried it yet but maybe if you have more then 1 email account it takes the settings from the main account and puts it on all of the other accounts. Can someone test this?
 

Hondamaker

Genius
Gold
May 14, 2007
9,922
662
113
55
Fairborn, Ohio
#8
I haven't tried it yet but maybe if you have more then 1 email account it takes the settings from the main account and puts it on all of the other accounts. Can someone test this?
My main, default acct is set to delete after 7 days, and my second acct always reverts to 'never'. My main acct stays the same.
 

rumpelgeist

New Member
Bronze
Jun 20, 2007
165
0
0
#9
Bizarre, bizarre, bizarre!

Just on a hunch, I tried something: I just added a second, duplicate copy of my primary email account. Then I went into the original copy of that account and changed the "delete from server" setting to "When removed from inbox."

Since adding the second copy of that email address, the setting for the original copy is staying where it should (where I set it) and is actually deleting the email from the server as it should.

I went in and deleted the second copy of the email account, and the setting on the original copy is still holding.

So this seems to have fixed my problem. Anyone else with this issue might want to give this a shot.

I love this little phone, but man does it do some WEIRD things at times.

Rumpelgeist