Mail won't download after having no signal

RyanP

Member
Bronze
Jul 26, 2007
51
0
6
#1
I get pretty much no signal in my office all day long. I've noticed that a lot of days when I get out of work, my iPhone will no longer download mail. Even if I go to the Inbox and hit that refresh icon, it will start "spinning" but nothing will ever happen. If I send a mail, it never gets sent. If I go to a mail with a photo and click the "download photo" button, it will spin but never download. To correct the problem, I have to turn the phone off and then on (I've tried going to airplane mode and back and other things, but nothing works to force it to get mail except turning it off and then on). This is especially frustrating b/c if I write a mail and send it (not realizing it's in this "frozen" state), the mail never gets sent, and then it gets lost when I turn it off and then on. Even if I enter a wifi network, the mails will still not download (and I've even tried turning wifi off and then on and trying to get mail again).

Has anybody else had this problem? Does anybody know a fix? It's happened for the past few release versions too (I keep hoping a release upgrade will fix it).

Thanks for any help,
Ryan
 

FlwrPwer

Evangelist
Gold
Aug 7, 2008
1,855
77
63
39
Montgomery, NY
#2
This is a common problem. Mail gets sorta stuck when it's checking and you go from one connection to another.

As of right now, the only fix I know of is to turn it on and off. Someone might know more....but that's all I know.

Sorry I couldn't be more help :)
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#3
I get pretty much no signal in my office all day long. I've noticed that a lot of days when I get out of work, my iPhone will no longer download mail. Even if I go to the Inbox and hit that refresh icon, it will start "spinning" but nothing will ever happen. If I send a mail, it never gets sent. If I go to a mail with a photo and click the "download photo" button, it will spin but never download. To correct the problem, I have to turn the phone off and then on (I've tried going to airplane mode and back and other things, but nothing works to force it to get mail except turning it off and then on). This is especially frustrating b/c if I write a mail and send it (not realizing it's in this "frozen" state), the mail never gets sent, and then it gets lost when I turn it off and then on. Even if I enter a wifi network, the mails will still not download (and I've even tried turning wifi off and then on and trying to get mail again).

Has anybody else had this problem? Does anybody know a fix? It's happened for the past few release versions too (I keep hoping a release upgrade will fix it).

Thanks for any help,
Ryan
This sounds similar to what I experienced when AT&T was doing network upgrades in my area. I could only make and receive calls , but data was down.
Go into Settings, General, Resets, and reset network settings. Test that and see if things clear up for you.

BTW, what Firmware version and what type of phone are you using? Version 1, or 3G?
 

RyanP

Member
Bronze
Jul 26, 2007
51
0
6
#4
Thanks, Hawk...I'll try that this afternoon. Will that mess with any of my WiFi networks (like will I lose network keys I've typed in)? I'm on an original iPhone with V 2.1 software. I appreciate the help!
Ryan
 

Hawk

Genius
Gold
Aug 2, 2007
6,682
241
83
49
ATL
#5
Thanks, Hawk...I'll try that this afternoon. Will that mess with any of my WiFi networks (like will I lose network keys I've typed in)? I'm on an original iPhone with V 2.1 software. I appreciate the help!
Ryan
Yes, you will lose your security keys for any Networks you were connected to or have settings for.
I tested it for you a few minutes ago.
It resets Ring tone, message tone, brightness, wifi connections, it removed my exchange setup for my calendar, it does a little bit of "damage", but that was a reset all settings too.
Reseting just network settings will only wipe out your security keys