Message coming from email address instead of phone number

Discussion in 'iOS 8' started by brdmsd, Oct 10, 2014.

  1. brdmsd

    brdmsd Member
    Bronze

    Joined:
    Jul 18, 2007
    Likes Received:
    10
    My iPhone suddenly started to indicate ( to the receiver of the message)that the message was coming from my email message rather than my phone. How do I correct this?
     
  2. coop1701

    coop1701 Zealot
    Silver

    Joined:
    Jun 30, 2007
    Likes Received:
    110
    If it was sent as a iMessage. It will sometimes do that. Usually you have a Phone # in iMessage along with any emails that you have associated for that device. It just means it skipped the primary for (What Ever Reason) and went out via email address. Could have been a temporary issue with your carrier or sometimes a reboot of your phone will fix it. It also helps if the person on the other side, adds that email to your Normal Contact Information. That way the name displays right in the messages App.
     
  3. shutter13

    shutter13 Evangelist
    Gold

    Joined:
    Jan 8, 2009
    Likes Received:
    117
    Mine did that, so I unlinked my email address in settings. At that point my messages went out as texts only, no iMessage, so I turned off iMessage, and turned it back on and it started working again.
     
  4. Ledsteplin

    Ledsteplin Genius
    Gold

    Joined:
    Oct 29, 2013
    Likes Received:
    942
    In "Send and Receive", it's the bottom part you want only the phone number checked. To send. The top part to receive can be checked for email. That shouldn't affect anything. But uncheck emails in "Start New Conversations From".
    ImageUploadedByTapatalk1413043995.641191.jpg


    Sent from my ancient but trustworthy iPhone 5
     

Share This Page