MMS on iPhone 3G, weird....

#1
so i read where you had to do some crazy stuff to get your MMS enabled and how they said at the conference it wouldn't be available til the end of the summer.. however..



i just did it. i just enabled /shrug. This is a good forum. i am enjoying the new software. so glad i'm a dev account holder.
 

karllf

Member
Bronze
Aug 17, 2007
49
0
6
#2
what's this (enabled /shrug ) and how do i do that to my phone ?
 

Youngbinks

Zealot
Gold
Jun 4, 2007
7,617
3
38
31
Atlanta, Georgia
#4
I had MMS working on Beta 1 and some have had it on Betas 1-5. A few people even have it on the 3.0 GM release. No one really knows why.
 
Dec 17, 2008
16
0
0
#5
I had it on beta 3, and then when beta 4 came out, I didn't upgrade to that because I didn't need to, beta 3 was perfect for me, then when beta 5 came out they shut down all phones using beta 3, so I was stuck at work all day without a phone, then forced to upgrade to beta 5 and because I reset it up like a new ipod instead of actually upgrading (even though I am under a developers account) I lost my mms and have no clue why att took it away.
 

Watcher

Zealot
Gold
Mar 29, 2009
1,785
30
48
Phoenix, AZ
#6
I had MMS working on Beta 1 and some have had it on Betas 1-5. A few people even have it on the 3.0 GM release. No one really knows why.
I've got MMS working on 3.0 GM! :laugh2:

Of course, I never updated my iTunes 8.2 to the public one until AFTER I put the GM on it.
 

billinaz

Member
Bronze
Jan 27, 2008
164
2
18
#9
I got mine working again.

Here is what I did:

Originally Posted by shutter13
I PM'd these instructions to someone, your welcome to use them, if they help.

Ok this is assuming you are using the official iTunes 8.2 and windows. I think a mac would be similar but don't have one so can't be sure.

1) install GM seed on iPhone.
2) restore from back up or set up as new
3) uninstall official 8.2
4) uninstall Apple mobile device support
5) install iTunes 8.2 tha shipped with beta 4
http://www.megaupload.com/?d=87VM6HFC[/COLOR][/URL]
iTunessetupwindows.zip
6) move your iTunes library file (iTunes.itl) to a different location if it was updated with the official 8.2
7) open iTunes
8) update your ipcc file with this one
http://www.megaupload.com/?d=J84S5YPV[/COLOR][/URL]
Update the same way you do the ipsw just change the file type to ipcc and navigate to the file
9) restart your phone and the mms options should be there
10) uninstall beta 4 iTunes 8.2
11) uninstall Apple mobile device support
12) reinstall official 8.2 and replace the empty iTunes.itl with the one you moved. You should be good to go, provided your account is provisioned for mms.
 
Last edited by a moderator:

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#11
If they already had an updated carrier file and the updated rather than restored...no one had to to all that stuff. Now if your with a different carrier than AT&T, than that's another story, and quite possibly something else to brag about.
 

shutter13

Evangelist
Gold
Jan 8, 2009
2,208
153
63
#13
Are you with AT&T? Did you ever update to a custom ipcc file?
 

styfle

Zealot
Gold
Mar 31, 2008
3,381
7
38
#15
did you use any betas before the GM?
 

hotskate

Member
Bronze
Sep 21, 2007
314
1
18
34
#16
i spoke to att all day today i am provisioned and all and still no luck with the mms and multie person text message ughh