Mp3 playes in iTunes but not on iPhone?

Painkiller

New Member
Bronze
Aug 9, 2007
38
0
0
#1
Strange prob here. Every once in a while I'll get a song that just will not play on my iPhone BUT, will play just fine on iTunes.

I just added a new song folder to my iTunes collection and it plays with no prob on my laptop using iTunes. Dragged the file over to my hooked up iPhone and it copied no problem. I can even play it from my iPhone music file when I select it through iTunes BUT...when I try to play it directly on my iPhone, the song is completely silent.

I can see the time progessing showing that it's playing. It seems to have copied just fine. Artwork is there as well. Just no audio at all.

Checked to make sure the volume adjustment wasn't needed on the file and, it wasn't.

Tried selecting "convert to mp3" from the drop down menu on iTunes, even though it's already an mp3. Didn't help either.

Not sure what the prob is. I'm using an unjailbroken iPhone running 1.1.4. firmware and the latest/greatest iTunes.

Any ideas are definitely appreciated.
 

colombianito

New Member
Bronze
Sep 12, 2007
166
0
0
#2
i think this is what you did....

you had the song in one folder, then you went to iTunes and selected the songs you wanted to sync to your iPhone, you sync'ed your iPhone...after a while, for some reason you moved the song from the folder where it was to a new folder, iTunes found it, put it on its library, making a copy of the song, one song in folder a and the other song in forlder b.

since you didn't notice the duplicate, you never check the "new" song to be sync'ed to your iPhone and so it never was... and so you never uncheck the "old" song to be removed...

well, when you sync' your iPhone, the song remains there, but it is "blank" since the song you had originaly checked to be synced to your iPhone is not there anymore, and when you check on iTunes you r probably paying the song from its new location...

i think thats the problem, check for duplicates...
 

Painkiller

New Member
Bronze
Aug 9, 2007
38
0
0
#3
Thanks for trying to help! Wouldn't have thought of that however, I don't think that's the prob. Although, I did originally download the file to a certain folder, then double clicked on that file to see how it sounded, played fine in iTunes, then I cut and pasted to my regular music folder.

When trying to play the file again, of course I had to redirect iTunes to the new folder I put it in. Did that just fine. Deleted the "old" folder that was empty, although I had to shut down iTunes because XP wouldn't let me delete it since it kept saying it was still being used by another program.

Anyhoo, the original empty folder is deleted and iTunes has been redirected to the new folder. Dragged the mp3 from the main music to the iPhone music. Copied fine. Still the same prob: song plays just fine when I select it through iTunes, both the iTunes music on my pc AND on my iPhone. It's just when I directly select it from my iPhone, it get zip.

With my iPhone hooked up and iTunes running, I tried a different mp3 from my iPhone music files and it played just fine through my pc. While it was playing through the pc, I also tried to play it at the same time directly from the iPhone. It did. The song was playing through my pc speakers and from my iPhone speaker at the same time.

Tried the exact same thing with this mp3 that's giving me these problems and, it played just fine from my iPhone through iTunes on my pc but, while it was playing through my pc I tried to play it directly from my iPhone just like the other file and, no good. Plays fine through the pc but, from the iPhone there is nothing but the progression of time being shown as though it is playing something.

I can't seem to figure this one out at all....?

How could it be corrupt on the iPhone BUT...still be able to play from the iPhone music files except only able to be heard correctly through the pc? :oops: :mad:
 

Painkiller

New Member
Bronze
Aug 9, 2007
38
0
0
#4
Actually, there's more to it now. If I hold up my iPhones speaker to my ear, I can very very faintly hear the song playing...? Adjusting the volume boost doesn't do anything.

Okay, I'm officially stumped! LOL "Anyone? Buhler? Buhler?"